String HDU - 4821

版权声明:如有错误,请指出,不胜感激。 https://blog.csdn.net/qq_36424540/article/details/83506410

Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.

Input

The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.

Output

For each test case, output the answer in a single line.

Sample Input

3 3
abcabcbcaabc

Sample Output

2

1.那个base值得是 素数,不是很理解原理

2.ULL 自然溢出,不用担心

#include<bits/stdc++.h>
using namespace std;

typedef unsigned long long ULL;
typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)

const int N=1e5+10;
char str[N];
unordered_map<ULL,int> has;

ULL dig=31;
ULL base[N],sum[N];
ULL val[N];

int main(){
    //freopen("123.txt","r",stdin);
    //freopen("789.txt","w",stdout);
    base[0]=1;
    rep(i,1,N)base[i]=base[i-1]*dig;//自然溢出

    int m,L;
    while(scanf("%d %d",&m,&L)==2){
        scanf("%s",str+1);
        int len=strlen(str+1);
        LL ans=0;

        for(int i=1;i<=len;i++)sum[i]=(sum[i-1]*dig+str[i]-'a');

        for(int j=0;j<L;j++){
            has.clear();
            int l=0,r=0;
            for(int i=1+j;i+L-1<=len;i+=L){
                ULL res=(sum[i+L-1]-sum[i-1]*base[L]);
                val[++r]=res;
                if(has[res]){
                    while(l<r){
                        has[val[++l]]--;
                        if(val[l]==res)break;
                    }
                    has[res]++;
                }else{
                    has[res]++;
                }

                if(r-l>=m) ans++;
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/83506410
今日推荐