POJ 2034

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. 

We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9. 

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output 

No anti-prime sequence exists. 

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54、

题意:

从n,n+1,n+2,,,,,,m,个数,使相邻的i(2<=i<=d)个数的和为合数,找到字典序最小的排列。

代码:

#include<cstdio>
#include<cstring>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=10000+5;
int prime[maxn];//prime[i]==0表示 i为素数
vector<int> ans;
vector<int> sum;
int n,m,d;
bool vis[1000+5];
bool DFS(int cnt,int all)//当前已经构造了cnt个数,且这cnt个数的和等于all
{
    if(cnt>=2)//cnt>=2时,才需要判断连续i个值的和是否为合数. 且这里我们只需要判断后缀即可
    {
        for(int len=2;len<=min(cnt,d);len++)
        {
            int pre_sum = sum[cnt-len];          //求出前cnt-len个数的和,即sum[cnt-len]
            if(!prime[all-pre_sum]) return false;//长度为len的后缀和是素数,非法
        }
    }
    if(cnt==m-n+1) return true;
    for(int i=n;i<=m;i++)if(!vis[i])
    {
        vis[i]=1;
        ans.push_back(i);
        int temp_sum= all+i;
        sum.push_back(temp_sum);
        if(DFS(cnt+1,all+i)) return true;
        else
        {
            vis[i]=0;
            ans.pop_back();
            sum.pop_back();
        }
    }
    return false;
}
 
int main()
{
    for(int i=2;i<maxn;i++)if(prime[i]==0)
    {
        for(int j=i*i; j<maxn; j+=i)
            prime[j]=1;
    }
    while(scanf("%d%d%d",&n,&m,&d)==3&&n)
    {
        memset(vis,0,sizeof(vis));
        ans.clear();
        sum.clear();
        sum.push_back(0);
        if(DFS(0,0))
        {
            printf("%d",ans[0]);
            for(int i=1;i<ans.size();i++)
                printf(",%d",ans[i]);
            printf("\n");
        }
        else printf("No anti-prime sequence exists.\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_40859951/article/details/84579239