1101 谁是中间那个

问题描述:

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 
Input
* Line 1: A single integer N <br> <br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 
Output
* Line 1: A single integer that is the median milk output.
 
Sample Input
5
2
4
1
3


Sample Output

思路:

使用堆排序或者快速排序或者用sort(buffer,buffer+n,cmp);

cmp是自己定义的一个排序规则,返回值为ture或者false。

sort()函数默认升序排序,类型包括升序,字符型,字符串,结构体。

使用结构体类型数组排序,就要用到cmp函数。

这道题中

typedef struct{
   int MakeMilk;
   int num;
}COW
bool cmp(COW A,COW B)
{
    if(A.MakeMilk<B.MakeMilk) return true;
    if(A.MakeMilk==B.MakeMilk&&A.num>B.num) return true;
    true false;
}

完整代码如下:

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<stdio.h>
using namespace std;
typedef struct{
    int MakeMilk;
    int num;
}COW;
bool cmp(COW A,COW B)
{
    if(A.MakeMilk<B.MakeMilk) return true;
    if(A.MakeMilk==B.MakeMilk&&A.num>B.num) return true;
    true false;
}
int main()
{
    COW cow[10005];
    int n;
    while (scanf("%d",&n)!==EOF)
    {
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&COW[i].MakeMilk);
            cow[i].num=i;
        }
        sort(cow+1;cow+1+n;cmp);
        printf("%d\n",cow[(n+1)/2].MakeMilk);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/HIsckey/article/details/81025391
今日推荐