D - Going Home 最小费用最大流

On a grid map there are n little men and n houses. In each unit time, every little man can move one unit step, either horizontally, or vertically, to an adjacent point. For each little man, you need to pay a $1 travel fee for every step he moves, until he enters a house. The task is complicated with the restriction that each house can accommodate only one little man. 

Your task is to compute the minimum amount of money you need to pay in order to send these n little men into those n different houses. The input is a map of the scenario, a '.' means an empty space, an 'H' represents a house on that point, and am 'm' indicates there is a little man on that point. 


You can think of each point on the grid map as a quite large square, so it can hold n little men at the same time; also, it is okay if a little man steps on a grid with a house without entering that house.

Input

There are one or more test cases in the input. Each case starts with a line giving two integers N and M, where N is the number of rows of the map, and M is the number of columns. The rest of the input will be N lines describing the map. You may assume both N and M are between 2 and 100, inclusive. There will be the same number of 'H's and 'm's on the map; and there will be at most 100 houses. Input will terminate with 0 0 for N and M.

Output

For each test case, output one line with the single integer, which is the minimum amount, in dollars, you need to pay.

Sample Input

2 2
.m
H.
5 5
HH..m
.....
.....
.....
mm..H
7 8
...H....
...H....
...H....
mmmHmmmm
...H....
...H....
...H....
0 0

Sample Output

2
10
28

题意:求每个人都进入一个房间所花费的最小费用 模板题

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
char mapp[110][110];
int n,m;
int pre[1100],dis[1100],head[1100],cnt;
int vis[1100];
struct node
{
    int u,v,cap,cost,to;//多加一个费用的边
}s[44000];
struct point
{
    int x,y;
}a[500],b[500];
void add(int u,int v,int cost,int cap)
{
  s[cnt].u=u;
  s[cnt].v=v;
  s[cnt].cost=cost;
  s[cnt].cap=cap;
  s[cnt].to=head[u];
  head[u]=cnt++;
  s[cnt].u=v;
  s[cnt].v=u;
  s[cnt].cost=-cost;//反向赋值为负
  s[cnt].cap=0;
  s[cnt].to=head[v];
  head[v]=cnt++;
}
int spfa(int ss,int t)
{
    queue<int>q;
    q.push(ss);
    memset(vis,0,sizeof(vis));//表示该点是不是被找过了
    memset(pre,-1,sizeof(pre));//存储路径
    for(int i=ss;i<=t;i++)
    {
        dis[i]=inf;
    }
    dis[ss]=0;
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int e=head[u];~e;e=s[e].to)
        {
            int v=s[e].v,cap=s[e].cap;
            if(cap&&dis[v]>dis[u]+s[e].cost)
            {//更新最小花费,
                dis[v]=dis[u]+s[e].cost;
                pre[v]=e;
                if(!vis[v])
                {
                    vis[v]=1;
                    q.push(v);
                }
            }
        }
        vis[u]=0;
    }
    if(dis[t]!=inf)
        return 1;
    return 0;
}
void solve(int ss,int t)
{
    int ans=0;
    int flow=0,cost=0;
    while(spfa(ss,t))
    {
        //printf("**\n");
        int minf=inf;
        for(int i=pre[t];i!=-1;i=pre[s[i].u])
        {//printf("666\n");
            if(s[i].cap<minf)
            {
                minf=s[i].cap;
            }
        }
        flow+=minf;//找到该路径的最小流
        for(int i=pre[t];i!=-1;i=pre[s[i].u])
        {
            s[i].cap-=minf;
            s[i^1].cap+=minf;
        }
        cost+=dis[t]*minf;//
        //printf("***\n");
    }
    printf("%d\n",cost);
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        cnt=0;
        if(n==0&&m==0)
            return 0;
            int sum=1,num=1;
            memset(head,-1,sizeof(head));
        for(int i=1;i<=n;i++)
        {
            scanf("%s",mapp[i]+1);
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
               if(mapp[i][j]=='m')
               {
                   a[sum].x=i;
                   a[sum].y=j;
                   sum++;
               }
               if(mapp[i][j]=='H')
               {
                   b[num].x=i;
                   b[num].y=j;
                   num++;
               }
            }
        }
        int s=0,tt=sum-1+num-1+1;
        for(int i=1;i<sum;i++)
        {
            for(int j=1;j<num;j++)
            {
                int di=abs(a[i].x-b[j].x)+abs(a[i].y-b[j].y);
                add(i,j+sum-1,di,1);
            }
        }
        for(int i=1;i<sum;i++)
        {
            add(s,i,0,1);
        }
        for(int i=1;i<num;i++)
        {
            add(i+sum-1,tt,0,1);
        }
       // printf("*\n");
        solve(s,tt);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/Kuguotao/article/details/83756617
今日推荐