poj2833优先队列STL版

The Average

Time Limit: 6000msMemory Limit: 10000KB 64-bit integer IO format: %lld Java class name: Main
Submit Status
In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.-
Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ i ≤ n) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000
Hint
This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

#include<iostream>
#include<queue>
#include<cstdio>
#include<cstdlib>
using namespace std;
priority_queue<double,vector<double>,greater<double> >big;//定义一个最小优先队列,根节点为最小
priority_queue<double>small;//定义一个最大优先队列
int main()
{
	int n1=0,n2=0,n=0;
	double temp=0,sum=0;	
	while((scanf("%d%d%d",&n1,&n2,&n)==3)&&(n1!=0)&&(n2!=0)&&(n!=0))
	{
		sum=0;
		while(!big.empty())
		  big.pop();
		while(!small.empty())
		  small.empty();	
		for(int i=1;i<=n;i++)
		{
			scanf("%lf",&temp);
			big.push(temp);
			if(big.size()>n1)
			  big.pop();
			small.push(temp);
			if(small.size()>n2)
			  small.pop();
			sum+=temp;
		}
		for(int i=1;i<=n1;i++)
		{
			sum-=big.top();
			big.pop();
		}
		for(int i=1;i<=n2;i++)
		{
			sum-=small.top();
			small.pop();
		}
		sum=sum/(n-n1-n2);
		printf("%.6lf\n",sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/m0_43400575/article/details/84671916