poj2833(优先队列)

poj2833

The Average

Time Limit: 6000MS   Memory Limit: 10000K
Total Submissions: 13177   Accepted: 3926
Case Time Limit: 4000MS

Description

In a speech contest, when a contestant finishes his speech, the judges will then grade his performance. The staff remove the highest grade and the lowest grade and compute the average of the rest as the contestant’s final grade. This is an easy problem because usually there are only several judges.

Let’s consider a generalized form of the problem above. Given n positive integers, remove the greatest n1 ones and the least n2 ones, and compute the average of the rest.

Input

The input consists of several test cases. Each test case consists two lines. The first line contains three integers n1, n2 and n (1 ≤ n1, n2 ≤ 10, n1 + n2 < n ≤ 5,000,000) separate by a single space. The second line contains n positive integers ai (1 ≤ ai ≤ 108 for all i s.t. 1 ≤ in) separated by a single space. The last test case is followed by three zeroes.

Output

For each test case, output the average rounded to six digits after decimal point in a separate line.

Sample Input

1 2 5
1 2 3 4 5
4 2 10
2121187 902 485 531 843 582 652 926 220 155
0 0 0

Sample Output

3.500000
562.500000

Hint

This problem has very large input data. scanf and printf are recommended for C++ I/O.

The memory limit might not allow you to store everything in the memory.

Source

POJ Monthly--2006.05.28, zby03

就是题意开始读错了。。。。。

把n1个大的,n2个小的去掉,求均值。

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<queue>
using namespace std;
typedef long long LL;
int n1,n2,n;
LL sum;
int main()
{
    int x;
    while(scanf("%d%d%d",&n1,&n2,&n)){
        if(n==0)
        break;
        sum=0;
        priority_queue<int>da;
        priority_queue<int,vector<int>,greater<int> >xiao;
        for(int i=1;i<=n;i++){
            scanf("%d",&x);
            sum+=x;
            da.push(x);
            xiao.push(x);
            if(da.size()>n2)
                da.pop();
            if(xiao.size()>n1)
                xiao.pop();
        }
        while(da.size()>0){
            int xpp=da.top();
            sum-=xpp;
            da.pop();
        }
        while(xiao.size()>0){
            sum-=xiao.top();
            xiao.pop();
        }
        double lala=sum*1.0/(n-n1-n2);
        printf("%.6f\n",lala);
    }
}
发布了565 篇原创文章 · 获赞 110 · 访问量 11万+

猜你喜欢

转载自blog.csdn.net/xianpingping/article/details/86894783