Til the Cows Come Home (有向图最短路径问题)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: NM, and X 
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai,Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

       这是一道有向图最短路径问题,题意是有n个点,m条有向边,给定点x,求从其余n-1个点到点x最短路径的最大值

一开始用Dijkstra算法,求出每个点到其余n-1个点的最短路径,时间复杂度为O(n^2),可惜TimeLimit,所以考虑另一种算法

SPFA,时间复杂度O(n)

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define Inf 0x3f3f3f3f
const int N=1005;
int g[N][N];
int vis[N];
int dis[N][N];
int n,m,x;
void Init()
{
	memset(g,Inf,sizeof(g));
	for(int i=1;i<=n;i++)
	    g[i][i]=0;
}
void GetMap()
{
	for(int i=0;i<m;i++)
	{
		int u,v,d;
		cin>>u>>v>>d;
		if(g[u][v]>=d)
		  g[u][v]=d;
	}
}
void Dijkstra(int s)
{
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++)
	    dis[s][i]=g[s][i];
	vis[s]=1;
	int u=s;
	for(int k=1;k<n;k++)
	{
		int minn=Inf;
		for(int i=1;i<=n;i++)
		   if(dis[s][i]<minn && !vis[i])
		   {
		   	   minn=dis[s][i];
		   	   u=i;
		   }
		vis[u]=1;
		for(int i=1;i<=n;i++)
		{
			if(dis[s][i]>dis[s][u]+g[u][i])
			     dis[s][i]=dis[s][u]+g[u][i];
		}
	}
}
int main()
{
	cin>>n>>m>>x;
	Init();
	GetMap();
	for(int i=1;i<=n;i++)
     	Dijkstra(i);
	int ans=0;
	for(int i=1;i<=n;i++)
	{
		if(i!=x)
		{
			ans=max(ans,dis[i][x]+dis[x][i]);
	    }   
		   
	}
	cout<<ans<<endl;
	return 0;
}

SPFA算法

猜你喜欢

转载自blog.csdn.net/daoshen1314/article/details/84262383