Fast Matrix Calculation题解

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Little_Small_Joze/article/details/79450953

One day, Alice and Bob felt bored again, Bob knows Alice is a girl who loves math and is just learning something about matrix, so he decided to make a crazy problem for her. 

Bob has a six-faced dice which has numbers 0, 1, 2, 3, 4 and 5 on each face. At first, he will choose a number N (4 <= N <= 1000), and for N times, he keeps throwing his dice for K times (2 <=K <= 6) and writes down its number on the top face to make an N*K matrix A, in which each element is not less than 0 and not greater than 5. Then he does similar thing again with a bit difference: he keeps throwing his dice for N times and each time repeat it for K times to write down a K*N matrix B, in which each element is not less than 0 and not greater than 5. With the two matrix A and B formed, Alice’s task is to perform the following 4-step calculation. 

Step 1: Calculate a new N*N matrix C = A*B. 
Step 2: Calculate M = C^(N*N). 
Step 3: For each element x in M, calculate x % 6. All the remainders form a new matrix M’. 
Step 4: Calculate the sum of all the elements in M’. 

Bob just made this problem for kidding but he sees Alice taking it serious, so he also wonders what the answer is. And then Bob turn to you for help because he is not good at math.
InputThe input contains several test cases. Each test case starts with two integer N and K, indicating the numbers N and K described above. Then N lines follow, and each line has K integers between 0 and 5, representing matrix A. Then K lines follow, and each line has N integers between 0 and 5, representing matrix B. 

The end of input is indicated by N = K = 0.OutputFor each case, output the sum of all the elements in M’ in a line.Sample Input
4 2
5 5
4 4
5 4
0 0
4 2 5 5
1 3 1 5
6 3
1 2 3
0 3 0
2 3 4
4 3 2
2 5 5
0 5 0
3 4 5 1 1 0
5 3 2 3 3 2
3 1 5 4 5 2
0 0
Sample Output
14
56

AC C++:

#include <iostream>  
#include <cstdio>  
#include <cstring>  
//#define DEBUG
using namespace std;  
int n,k;  

struct matrix  
{  
    int map[7][7];  
    matrix()
    {
    	memset(map,0,sizeof(map));
	} 
};
  
matrix mult(matrix a,matrix b)  
{  
    matrix c;  
    for(int i=1;i<=k;i++)  
        for(int j=1;j<=k;j++)  
        {  
            for(int m=1;m<=k;m++)    
                c.map[i][j]=(c.map[i][j]+a.map[i][m]*b.map[m][j]);
            c.map[i][j]%=6;  
        }  
    
    return c;  
}  

matrix pow_mult(matrix a,int x)  
{  
    matrix c;  
    for(int i=1;i<=k;i++)  
        for(int j=1;j<=k;j++)  
            c.map[i][j]=(i==j);  
    
    while(x)
    {  
        if(x&1)c=mult(c,a);
		x>>=1;  
        a=mult(a,a);  
    }  
    return c;  
}  

int a[1005][7],b[7][1005],final[7][1005],mid[7][7],last[1005][1005],sum;  
/*
发现使用快速幂矩阵之后依然超时,非常绝望,后来就把 (A*B)^(n*n-1)拆开变成 A*(A*B)^(n*n-1)*B,
然后拆出来的一个A和一个B用 数组 而非 结构体 ,直接在 main() 里面计算 而非 传递到子函数,以此节省时间来AC代码。 
但是一定要注意矩阵乘法是不可以颠倒左右两个矩阵的次序的,
因此最后乘以A 然后再 乘以B的时候一定要保证顺序和循环界限不要写错。

*/
int main()  
{  
#ifdef DEBUG	
	freopen("try.txt","r",stdin);
#endif 
    while(scanf("%d%d",&n,&k) && (n!=0)&&(k!=0))   
    {  
      for(int i=1;i<=n;i++)  
        for(int j=1;j<=k;j++)  
        	scanf("%d",&a[i][j]);     
      
      for(int i=1;i<=k;i++)  
        for(int j=1;j<=n;j++)  
	        scanf("%d",&b[i][j]);     

      memset(mid,0,sizeof(mid));  
      ;
      for(int i=1;i<=k;i++)    
        for(int j=1;j<=k;j++)  
        {  
           for(int m=1;m<=n;m++)    
             	mid[i][j]=mid[i][j]+b[i][m]*a[m][j];              
           mid[i][j]%=6;      
        }  
  
      matrix ans;  
      for(int i=1;i<=k;i++)  
        for(int j=1;j<=k;j++)  
            ans.map[i][j]=mid[i][j];  
      
#ifdef DEBUG      
      	for(int i=1;i<=k;i++)  
      	{  
	        for(int j=1;j<=n;j++)  
	        {
   		     	cout<<ans.map[i][j]<<' ';
			}
			cout<<endl;
		}
#endif
      
      ans=pow_mult(ans,n*n-1);  
      memset(final,0,sizeof(final));  
      for(int i=1;i<=k;i++)  
      {  
        for(int j=1;j<=n;j++)  
        {  
            for(int m=1;m<=k;m++)  
            {  
                final[i][j]=final[i][j]+ans.map[i][m]*b[m][j];  
            }  
            final[i][j]%=6;  
        }  
      }  
      memset(last,0,sizeof(last));  
      for(int i=1;i<=n;i++)  
      {  
        for(int j=1;j<=n;j++)  
        {  
            for(int m=1;m<=k;m++)  
            {  
                last[i][j]=(last[i][j]+a[i][m]*final[m][j]);  
            }  
            last[i][j]%=6;  
        }  
      }  
      sum=0;  
      for(int i=1;i<=n;i++)  
      {  
        for(int j=1;j<=n;j++)  
        {  
            sum+=last[i][j];  
        }  
      }  
      cout<<sum<<endl;  
    }  
    return 0;  
}

猜你喜欢

转载自blog.csdn.net/Little_Small_Joze/article/details/79450953