POJ - 1655 Balancing Act 树形dp

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:


Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

题解:son[u] 为u节点子代的个数  当子代找完后 n-1-son[u] 就为与u  与 父代连接的这条边  另一边节点的个数

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
using namespace std;
#define INF 0x3f3f3f3f
const int N = 20000 + 10;
vector<int> v[N];
int n, son[N], maxx[N];
void dfs(int u,int f) {
	son[u] = 0;
	maxx[u] = 0;
	for(int i = 0; i < v[u].size(); ++i) {
		int to = v[u][i];
		if(to == f) continue;
		dfs(to, u);
		son[u] += son[to];
		maxx[u] = max(maxx[u], son[to]);
	}
	maxx[u] = max(maxx[u], n - 1 - son[u]);
	son[u]++;
}
int main() {
	int T, x, y;
	scanf("%d", &T);
	while(T--) {
		scanf("%d", &n);
		for(int i = 1; i <= n; i++) v[i].clear();
		for(int i = 1; i < n; ++i) {
			scanf("%d %d", &x, &y);
			v[x].push_back(y);
			v[y].push_back(x);
		}
		dfs(1, 0);
		int ans = INF, id;
		for(int i = 1; i <= n; i++) {
			if(maxx[i] < ans) {
				ans = maxx[i];
				id = i;
			}
		}
		printf("%d %d\n", id, ans);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/mmk27_word/article/details/84072762