POJ1655

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:


Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2

题意:求树的重心。

思路:假设1为根节点,将无根树转化为有根树,然后从1出发跑一次dfs,记录以各点为根节点时其结点的数量。

然后再跑一次dfs,记录删除各点后的两棵树结点数量的最大值(一部分是该结点的子结点数量,另一部分是根节点的结点数量减去以该结点为根时的子树的结点数量)

#include<iostream>
#include<string.h>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
#include<cstring>
#include<algorithm>
using namespace std;
const int INF = 1<<30;
const int MAX = 20000+50;
int N;
vector<int> G[MAX];
int number[MAX];   //number[i]表示以i为根节点的树的结点数量
int bal[MAX];   //每个结点距离结点的最大值
int visit[MAX];


//从fa出发的各边,更新number数组
int dfs1(int fa)
{
    visit[fa] = 1;
    for (int i = 0; i < G[fa].size(); i++)
    {
        int v = G[fa][i];
        if (visit[v] == 0)
            number[fa] += dfs1(v);
    }
    return number[fa];
}

void dfs2(int i, int fa)
{
    for (int j = 0; j < G[i].size(); j++)
    {
        int v = G[i][j];
        int tmp = 0;
        if (v == fa)
            bal[i] = max(bal[i], number[1] - number[i]);
        else
        {
            bal[i] = max(bal[i], number[v]);
            dfs2(v, i);
        }
    }
}


void init()
{
    for (int i = 1; i <= N; i++)
        G[i].clear();
    for (int i = 1; i <= N; i++)
        number[i] = 1;
    memset(visit, 0, sizeof(visit));
    memset(bal, 0, sizeof(bal));
}

int main()
{
    int t;
    cin >> t;

    while(t--)
    {
        cin >> N;
        if (N == 1)
            cout << 1 << ' ' << 0 << endl;
        else if (N == 2)
        {
            int a, b;
            cin >> a >> b;
            cout << 1 << ' ' << 1 << endl;
        }
        else
        {
            init();
            for (int i = 0; i < N - 1;i++)
            {
                int a, b;
                cin >> a >> b;
                G[a].push_back(b);
                G[b].push_back(a);
            }
            dfs1(1);
            dfs2(1, -1);
            int ans = INF;
            int node = 0;
            for (int i = 1; i <= N; i++)
            {
                if (bal[i] < ans)
                {
                    ans = bal[i];
                    node = i;
                }
            }
            cout << node << ' ' << ans <<endl;
        }
    }

    return 0;
}










猜你喜欢

转载自blog.csdn.net/qq_39479426/article/details/81546201
今日推荐