LA 4349 树状数组解决简单组合数--思维

Description


N(3N20000) ping pong players live along a west-east street(consider the street as a line segment). Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can't choose a referee whose skill rank is higher or lower than both of theirs. The contestants have to walk to the referee's house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?

Input

The first line of the input contains an integer T(1T20) , indicating the number of test cases, followed by T lines each of which describes a test case.

Every test case consists of N + 1 integers. The first integer is N , the number of players. Then N distinct integers a1, a2...aN follow, indicating the skill rank of each player, in the order of west to east ( 1ai100000 , i= 1...N ).

Output

For each test case, output a single line contains an integer, the total number of different games.

Sample Input

1
3 1 2 3
Sample Output

1
题意:
一条大街上住着n个乒乓球爱好者,经常组织比赛。每个人都有一个技能值ai,每场比赛需要3个人:两名选手和一名裁判。规定裁判位置必须在两个选手的中间,而且技能值也必须在两个选手的中间,问一共能组织多少种比赛
思路:
考虑第i个人当裁判的情形,假设a1到a[i-1]中有ci个比ai小,那么就有(i-1)-ci个比ai大,同理,假设a[i+1]到an中有di个比ai小,那么就有(n-i)-di个比ai大,然后根据乘法原理和加法原理,i当裁判有ci(n-i-di)+(i-ci-1)*di,这样问题就转化为求c,d

#include<iostream>
#include<set>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<vector>
#include<cmath>
#include<queue>
using namespace std;
typedef long long ll;
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define mem(a,b) memset(a,b,sizeof a);
const int N = 1e5+7;
const int INF=0x3f3f3f3f;
int a[N];
int c[N];
int sum1[N],sum2[N];
int lowbit(int x)
{
    return x&-x;
}
int Sum(int x){
    int res=0;
    while(x>0){
        res+=c[x];
        x-=lowbit(x);
    }
    return res;
}
void add(int x,int val){
    while(x<=100000){
        c[x]+=val;
        x+=lowbit(x);
    }
    return ;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int t,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        rep(i,1,n) scanf("%d",&a[i]);
        memset(c,0,sizeof c);
        for(int i=1;i<=n;i++){//sum1记录的是在0--i-1之间有多少个比a[i]小的数;
            add(a[i],1);
            sum1[i]=Sum(a[i]-1);
        }
        memset(c,0,sizeof c);
        for(int i=n;i>=1;i--){//sum2记录的是在0--i-1之间有多少个比a[i]大的数;
            add(a[i],1);
            sum2[i]=Sum(a[i]-1);
        }
        ll ans=0;
        for(int i=1;i<=n;i++){
            ans+=sum1[i]*(n-i-sum2[i])+sum2[i]*(i-1-sum1[i]);
        }
        printf("%lld\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/c___c18/article/details/84295699
LA