HDOJ 1433 Simply Syntax

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/mml5211314/article/details/51103498

Simply Syntax



Problem Description
In the land of Hedonia the official language is Hedonian. A Hedonian professor had noticed that many of her students still did not master the syntax of Hedonian well. Tired of correcting the many syntactical mistakes, she decided to challenge the students and asked them to write a program that could check the syntactical correctness of any sentence they wrote. Similar to the nature of Hedonians, the syntax of Hedonian is also pleasantly simple. Here are the rules:

0. The only characters in the language are the characters p through z and N, C, D, E, and I.

1. Every character from p through z is a correct sentence.

2. If s is a correct sentence, then so is Ns.

3. If s and t are correct sentences, then so are Cst, Dst, Est and Ist.

4. Rules 0. to 3. are the only rules to determine the syntactical correctness of a sentence.

You are asked to write a program that checks if sentences satisfy the syntax rules given in Rule 0. - Rule 4.
 

Input
The input consists of a number of sentences consisting only of characters p through z and N, C, D, E, and I. Each sentence is ended by a new-line character. The collection of sentences is terminated by the end-of-file character. If necessary, you may assume that each sentence has at most 256 characters and at least 1 character.
 

Output
The output consists of the answers YES for each well-formed sentence and NO for each not-well-formed sentence. The answers are given in the same order as the sentences. Each answer is followed by a new-line character, and the list of answers is followed by an end-of-file character.

 

Sample Input
 
  
Cp Isz NIsz Cqpq
 

Sample Output
 
  
NO YES YES NO

1. Every character from p through z is a correct sentence. //每一个语法都由p到z贯穿,所以最后一个字母需为p到z

2. If s is a correct sentence, then so is Ns. //s语法正确,Ns语法也正确

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int fan(char a[])
{
	int sum=0,i,len;
	len=strlen(a);
	for (i=len-1;i>=0;i--)//倒着判断
	{
		if (a[i]>='p'&&a[i]<='z')
		sum++;
		else if (a[i]=='N')
		{
			continue;
		}
		else if(a[i]=='C'||a[i]=='D'||a[i]=='E'||a[i]=='I')
		sum--;
		else
		return 0;
		if (sum<1)
		return 0;
	}
	if (sum==1)
	return 1;
	else
	return 0;
}
int main()
{
	int i;
	char str[300];
	while (scanf ("%s",str)!=EOF)
	{
	//	gets(str);
		if (fan(str))
		printf ("YES\n");
		else
		printf ("NO\n");
	 } 
	return 0;
}















猜你喜欢

转载自blog.csdn.net/mml5211314/article/details/51103498
今日推荐