【Paths on a Grid】【POJ - 1942 】(高精度组合数)

版权声明:本人原创,未经许可,不得转载 https://blog.csdn.net/qq_42505741/article/details/83821508

题目:

Imagine you are attending your math lesson at school. Once again, you are bored because your teacher tells things that you already mastered years ago (this time he's explaining that (a+b) 2=a 2+2ab+b 2). So you decide to waste your time with drawing modern art instead. 

Fortunately you have a piece of squared paper and you choose a rectangle of size n*m on the paper. Let's call this rectangle together with the lines it contains a grid. Starting at the lower left corner of the grid, you move your pencil to the upper right corner, taking care that it stays on the lines and moves only to the right or up. The result is shown on the left: 


Really a masterpiece, isn't it? Repeating the procedure one more time, you arrive with the picture shown on the right. Now you wonder: how many different works of art can you produce?

Input

The input contains several testcases. Each is specified by two unsigned 32-bit integers n and m, denoting the size of the rectangle. As you can observe, the number of lines of the corresponding grid is one more in each dimension. Input is terminated by n=m=0.

Output

For each test case output on a line the number of different art works that can be generated using the procedure described above. That is, how many paths are there on a grid where each step of the path consists of moving one unit to the right or one unit up? You may safely assume that this number fits into a 32-bit unsigned integer.

Sample Input

5 4
1 1
0 0

Sample Output

126
2

解题报告:再一次被自己wa哭了,什么傻子操作,精度保持的0.5忘记加了,一直wa。题意就是从左下角跑到右上角一共有多少种方式,其实细想很简单就是C(m+n,min(m,n)).

扫描二维码关注公众号,回复: 4111902 查看本文章

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
	double n,m,t,sum,tmp;
	while(scanf("%lf%lf",&n,&m))
	{
		if(n==0&&m==0)
			break;
		if(n>m)
		{
			tmp=m;
			m=n;
			n=tmp;
		}
		t=m+n;
		sum=1.0;
		while(n>0)
		{
			sum*=t/n;
			t--;
			n--;
		}
		sum+=0.5;
		printf("%u\n",(unsigned int)sum);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_42505741/article/details/83821508
今日推荐