程序设计基础38 PAT A1016

1016 Phone Bills (25 分)

A long-distance telephone company charges its customers by the following rules:

Making a long-distance call costs a certain amount per minute, depending on the time of day when the call is made. When a customer starts connecting a long-distance call, the time will be recorded, and so will be the time when the customer hangs up the phone. Every calendar month, a bill is sent to the customer for each minute called (at a rate determined by the time of day). Your job is to prepare the bills for each month, given a set of phone call records.

Input Specification:

Each input file contains one test case. Each case has two parts: the rate structure, and the phone call records.

The rate structure consists of a line with 24 non-negative integers denoting the toll (cents/minute) from 00:00 - 01:00, the toll from 01:00 - 02:00, and so on for each hour in the day.

The next line contains a positive number N (≤1000), followed by N lines of records. Each phone call record consists of the name of the customer (string of up to 20 characters without space), the time and date (mm:dd:hh:mm), and the word on-line or off-line.

For each test case, all dates will be within a single month. Each on-line record is paired with the chronologically next record for the same customer provided it is an off-line record. Any on-line records that are not paired with an off-line record are ignored, as are off-line records not paired with an on-line record. It is guaranteed that at least one call is well paired in the input. You may assume that no two records for the same customer have the same time. Times are recorded using a 24-hour clock.

Output Specification:

For each test case, you must print a phone bill for each customer.

Bills must be printed in alphabetical order of customers' names. For each customer, first print in a line the name of the customer and the month of the bill in the format shown by the sample. Then for each time period of a call, print in one line the beginning and ending time and date (dd:hh:mm), the lasting time (in minute) and the charge of the call. The calls must be listed in chronological order. Finally, print the total charge for the month in the format shown by the sample.

Sample Input:

10 10 10 10 10 10 20 20 20 15 15 15 15 15 15 15 20 30 20 15 15 10 10 10
10
CYLL 01:01:06:01 on-line
CYLL 01:28:16:05 off-line
CYJJ 01:01:07:00 off-line
CYLL 01:01:08:03 off-line
CYJJ 01:01:05:59 on-line
aaa 01:01:01:03 on-line
aaa 01:02:00:01 on-line
CYLL 01:28:15:41 on-line
aaa 01:05:02:24 on-line
aaa 01:04:23:59 off-line

Sample Output:

CYJJ 01
01:05:59 01:07:00 61 $12.10
Total amount: $12.10
CYLL 01
01:06:01 01:08:03 122 $24.40
28:15:41 28:16:05 24 $3.85
Total amount: $28.25
aaa 01
02:00:01 04:23:59 4318 $638.80
Total amount: $638.80

一,注意点

1,先对结构体里面的名字进行字典序排序。

2,如何判断每个人的通话是否该被计算呢?通过变量isprint从0变为1表示开始通话,从1变到2说明通话结束。

二,代码

#include<cstdio>
#include<algorithm>
#include<string.h>
using namespace std;
const int max_n = 1010;
int cost[25];
struct Record{
	char name[30];
	int month;
	int day;
	int hour;
	int minute;
	char line[15];
	bool is_line;
}rec[max_n];
bool cmp(Record A,Record B){
	if(strcmp(A.name,B.name)!=0)return strcmp(A.name,B.name)<0;
	else if(A.month!=B.month)return A.month<B.month;
	else if(A.day!=B.day)return A.day<B.day;
	else if(A.hour!=B.hour)return A.hour<B.hour;
	else return A.minute<B.minute;
}
void get_ans(int on,int off,int &time,int &money){
	while(rec[on].day<rec[off].day||rec[on].hour<rec[off].hour||rec[on].minute<rec[off].minute){
		time++;
		money+=cost[rec[on].hour];
		rec[on].minute++;
		if(rec[on].minute>=60){
			rec[on].minute=0;
			rec[on].hour++;
//			money+=rec[on].hour;
			if(rec[on].hour>=24){
				rec[on].hour=0;
				rec[on].day++;
			}
		}	
	}
}
int main() {
	int N=0;
	for(int i=0;i<24;i++){
		scanf("%d",&cost[i]);
	}
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		scanf("%s",rec[i].name);
		scanf("%d:%d:%d:%d",&rec[i].month,&rec[i].day,&rec[i].hour,&rec[i].minute);
        scanf("%s",&rec[i].line);
		if(strcmp(rec[i].line,"on-line")==0){
			rec[i].is_line=true;
		}	
		else{
			rec[i].is_line=false;
		}	
	}
	sort(rec,rec+N,cmp);
	int on = 0;
	int off,next;
	while(on<N){
		int needPrint = 0;
		next = on;
		while(next<N&&strcmp(rec[next].name,rec[on].name)==0){
			if(needPrint==0&&rec[next].is_line==true){
				needPrint = 1;
			}
			else if(needPrint==1&&rec[next].is_line==false){
				needPrint = 2;
			}
			next++;
		}
		if(needPrint<2){
			on = next;
			continue;
		}
		int AllMoney=0;
		printf("%s %02d\n",rec[on].name,rec[on].month);
		while(on<next){
			while(on<next-1&&!(rec[on].is_line==true&&rec[on+1].is_line==false)){
				on++;
			}
			off=on+1;
			if(off==next){
				on = next;
				break;
			}
			printf("%02d:%02d:%02d ",rec[on].day,rec[on].hour,rec[on].minute);
			printf("%02d:%02d:%02d ",rec[off].day,rec[off].hour,rec[off].minute);
			int time=0,money=0;
			get_ans(on,off,time,money);
			printf("%d $%.2f\n",time,money/100.0);
			AllMoney+=money;
			on = off + 1;
		}
		printf("Total amount: $%.2f\n",AllMoney/100.0);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq2285580599/article/details/84070054