PAT乙级1016

1016 部分A+B(15 分)

正整数 A 的“D​A​​(为 1 位整数)部分”定义为由 A 中所有 D​A​​ 组成的新整数 P​A​​。例如:给定 A=3862767,D​A​​=6,则 A 的“6 部分”P​A​​ 是 66,因为 A 中有 2 个 6。

现给定 A、D​A​​、B、D​B​​,请编写程序计算 P​A​​+P​B​​。

输入格式:

输入在一行中依次给出 A、D​A​​、B、D​B​​,中间以空格分隔,其中 0<A,B<10​10​​。

输出格式:

在一行中输出 P​A​​+P​B​​ 的值。

输入样例 1:

3862767 6 13530293 3

输出样例 1:

399

输入样例 2:

3862767 1 13530293 8

输出样例 2:

0
#include<iostream>
#include<string>
using namespace std;
int main()
{
	string a,b;
	int c,d,sum,m=0,n=0;
	cin>>a>>c>>b>>d;
	int i;
	for(i=0;i<a.length();i++)
	{
		if(a[i]-'0'==c)
		{
			m=m*10+c;
		}
	}
	for(i=0;i<b.length();i++)
	{
		if(b[i]-'0'==d)
		{
			n=n*10+d;
		}
	}
	sum=m+n;
	cout<<sum<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/song68753/article/details/82314078