并查集的删除

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

scanf scanf scanf 以后都用scanf了

开两倍的数组,用n以后的数组成员来记录敌对关系,如果a和b+n是一伙的那么他俩就是敌对的,same函数用要有所体现 

#include<iostream>
using namespace std;
const int maxn = 200010; //开两倍 
int pre[maxn];
int n,m;
int Find(int x)
{
    if(pre[x]==x)
        return pre[x];
    else
        return pre[x]=Find(pre[x]);
} 
void merge(int x, int y)
{
   	int fx = Find(x);
	int fy = Find(y);
	if(fx != fy)
		pre[fx] = fy;
}
int same(int x, int y) 
{  
      if(Find(x)==Find(y))
          return 1;//相同 
      else if(Find(x)==Find(y+n))
          return 0;//不同 
      else
          return 2;//不确定 
}  
int main(){
	int t;
	scanf("%d",&t);
	char c;
	int a,b;
	while(t--){
		scanf("%d%d",&n,&m);
		for(int i=1;i<=2*n;i++){
			pre[i]=i;
		}
		for(int i=1;i<=m;i++){
			getchar();
			scanf("%c%d%d",&c,&a,&b);
            if(c=='A'){
				if(same(a,b)==0)
				    cout<<"In different gangs."<<endl;
				else if(same(a,b)==1)
				     cout<<"In the same gang."<<endl;
				else
				    cout<<"Not sure yet."<<endl;
			}
			else{
				merge(a,b+n);//标记为敌人 
				merge(a+n,b);//标记为敌人 
			}
		}	
	}
	return 0;
}



猜你喜欢

转载自blog.csdn.net/red_red_red/article/details/84074060