1081 Rational Sum (20 分)

1081 Rational Sum (20 分)

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
struct node
{
	ll num,den;
}s[105];
int main()
{
	ll n, a, b;
	scanf("%lld",&n);
	scanf("%lld/%lld",&a, &b);
	for(int i = 2 ; i <= n; i++)
	{
		scanf("%lld/%lld",&s[i].num, &s[i].den);
		if(b % s[i].den == 0 || s[i].den % b == 0)
		{
			ll gg = max(b,s[i].den);
			ll den = gg;
			ll num = gg / b * a + (gg / s[i].den * s[i].num);
			a = num;
			b = den;
		}else 
		{
			ll gg = __gcd(b,s[i].den);
			ll den = b * s[i].den / gg;
			ll num = den / b * a + den / s[i].den * s[i].num;
			b = den;
			a = num;	
		}
		
		ll gg = __gcd(a,b);
		a = a / gg;
		b = b / gg;
	}
		ll gg = __gcd(a,b);
		a = a / gg;
		b = b / gg;
	if(a % b == 0)
		printf("%lld\n",a / b);		
	else if(a >= b)
		printf("%lld %lld/%lld\n",a / b, a - (a / b * b),b); 
	else 
		printf("%lld/%lld\n",a,b);
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/galesaur_wcy/article/details/83898340