1081 Rational Sum (20point(s))

1081 Rational Sum (20point(s))

Given N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:
Each input file contains one test case. Each case starts with a positive integer N (≤100), followed in the next line N rational numbers a1/b1 a2/b2 … where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
struct fraction{
    
    
    ll up,down;
};
fraction reduction(fraction r){
    
    
    if(r.down<0){
    
    
        r.down=-r.down;
        r.up=-r.up;
    }
    int divisor=__gcd(abs(r.down),abs(r.up));
    r.up/=divisor;
    r.down/=divisor;
    return r;
}
fraction add(fraction r1,fraction r2){
    
    
    fraction r3;
    r3.down=r1.down*r2.down;
    r3.up=r1.down*r2.up+r2.down*r1.up;
    return reduction(r3);
}
void showResult(fraction r){
    
    
    r=reduction(r);
    if(r.down==1) printf("%lld\n",r.up);
    else if(abs(r.up)>r.down) printf("%lld %lld/%lld\n",r.up/r.down,abs(r.up)%r.down,r.down);
    else printf("%lld/%lld\n",r.up,r.down);
}
int main(){
    
    
    int n;
    cin>>n;
    fraction sum,temp;
    sum.down=1,sum.up-0;
    for(int i=0;i<n;++i){
    
    
        scanf("%lld/%lld",&temp.up,&temp.down);
        sum=add(sum,temp);
    }
    showResult(sum);
}

猜你喜欢

转载自blog.csdn.net/weixin_44970602/article/details/111698606