山东省第一届ACM大学生程序设计竞赛【floyd变形】

Emergency

题目描述

Kudo’s real name is not Kudo. Her name is Kudryavka Anatolyevna Strugatskia, and Kudo is only her nickname.
Now, she is facing an emergency in her hometown:
Her mother is developing a new kind of spacecraft. This plan costs enormous energy but finally failed. What’s more, because of the failed project, the government doesn’t have enough resource take measure to the rising sea levels caused by global warming, lead to an island flooded by the sea.
Dissatisfied with her mother’s spacecraft and the government, civil war has broken out. The foe wants to arrest the spacecraft project’s participants and the “Chief criminal” – Kudo’s mother – Doctor T’s family.
At the beginning of the war, all the cities are occupied by the foe. But as time goes by, the cities recaptured one by one.
To prevent from the foe’s arrest and boost morale, Kudo and some other people have to distract from a city to another. Although they can use some other means to transport, the most convenient way is using the inter-city roads. Assuming the city as a node and an inter-city road as an edge, you can treat the map as a weighted directed multigraph. An inter-city road is available if both its endpoint is recaptured.
Here comes the problem.
Given the traffic map, and the recaptured situation, can you tell Kudo what’s the shortest path from one city to another only passing the recaptured cities?

输入

The input consists of several test cases.
The first line of input in each test case contains three integers N (0< N≤300), M (0< M≤100000) and Q (0< Q≤100000), which represents the number of cities, the numbers of inter-city roads and the number of operations.
Each of the next M lines contains three integer x, y and z, represents there is an inter-city road starts from x, end up with y and the length is z. You can assume that 0< z≤10000.
Each of the next Q lines contains the operations with the following format:
a) 0 x – means city x has just been recaptured.
b) 1 x y – means asking the shortest path from x to y only passing the recaptured cities.
The last case is followed by a line containing three zeros.

输出

For each case, print the case number (1, 2 …) first.
For each operation 0, if city x is already recaptured (that is,the same 0 x operation appears again), print “City x is already recaptured.”
For each operation 1, if city x or y is not recaptured yet, print “City x or y is not available.” otherwise if Kudo can go from city x to city y only passing the recaptured cities, print the shortest path’s length; otherwise print “No such path.”
Your output format should imitate the sample output. Print a blank line after each test case.

样例输入

3 3 6
0 1 1
1 2 1
0 2 3
1 0 2
0 0
0 2
1 0 2
1 2 0
0 2

0 0 0

样例输出

Case 1:
City 0 or 2 is not available.
3
No such path.
City 2 is already recaptured.

题意概括:

  有n个城市,这些城市之间有m条路,每条路都有一个权值,但是这些城市都是沦陷的,只有被解放后才能通过路径联通。有两种操作0 x表示解放x城市,若 x 已经被解放输出“City 2 is already recaptured.”。 1 x y表示求出x 到 y的最小权值和。若x或y没有被解放则输出“City x or y is not available. ”,若不能到达输出“No such path. ”,若能到达直接输出其最小值。
 

解题思路:

  用floyd,先将所有路径存到邻接矩阵中,然后每解放一个城市就对其进行松弛,节省时间。

AC代码:

#include<stdio.h>
#include<cstring>
#include<algorithm>
using namespace std;

#define N 305
#define inf 99999999

int e[N][N];

void floyed(int n, int k)
{
    int i, j;
    for(i = 0; i < n; i++)
        for(j = 0; j < n; j++)
            e[i][j] = min(e[i][j], e[i][k]+e[k][j]);
}

int main()
{
    int i, j, n, q, t, x, y, z, T = 0;
    while(scanf("%d%d%d", &n, &t, &q), n||t||q){
        printf("Case %d:\n", ++T);
        int book[N] = {0};
        for(i = 0; i < n; i++){
            for(j = 0; j < n; j++)
                e[i][j] = inf;
            e[i][i] = 0;
        }
        while(t--){
            scanf("%d%d%d", &x, &y, &z);
            if(e[x][y] > z) e[x][y] = z;
        }
        while(q--){
            scanf("%d", &z);
            if(z){
                scanf("%d%d", &x, &y);
                if(!book[x] || !book[y]) printf("City %d or %d is not available.\n", x, y);
                else if(e[x][y] < inf) printf("%d\n", e[x][y]);
                else printf("No such path.\n");
                continue;
            }
            scanf("%d", &x);
            if(book[x]){
                printf("City %d is already recaptured.\n", x);
                continue;
            }
            book[x] = 1;
            floyed(n, x);
        }
        printf("\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/k_young1997/article/details/80159385