hdu 1542(扫描线模板)

Atlantis

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 19586    Accepted Submission(s): 7869


 

Problem Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

 

Input

The input file consists of several test cases. Each test case starts with a line containing a single integer n (1<=n<=100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0<=x1<x2<=100000;0<=y1<y2<=100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.

The input file is terminated by a line containing a single 0. Don’t process it.

 

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.

Output a blank line after each test case.

 

Sample Input

 

2 10 10 20 20 15 15 25 25.5 0

 

Sample Output

 

Test case #1 Total explored area: 180.00

 

Source

Mid-Central European Regional Contest 2000

 

Recommend

linle   |   We have carefully selected several similar problems for you:  1828 1255 1540 1823 2871 

 扫描线模板,求重叠矩形面积,离散化x坐标,再用线段树维护重叠,注意一下输出格式

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 2500
#define lson i*2,l,m
#define rson i*2+1,m+1,r
double X[maxn];
struct node
{
    double l,r,h;
    int d;
    node()
    {

    }
    node(double a,double b,double c,int d):l(a),r(b),h(c),d(d){}
    bool operator<(const node&b)const
    {
        return h<b.h;
    }
}nodes[maxn];
int cnt[maxn*4];
double sum[maxn*4];
void pushdown(int i,int l,int r)
{
    int m=(l+r)/2;
    if(cnt[i]!=-1)
    {
        cnt[i*2]=cnt[i*2+1]=cnt[i];
        sum[i*2]=(cnt[i]?(X[m+1]-X[l]):0);
        sum[i*2+1]=(cnt[i]?(X[r+1]-X[m+1]):0);

    }
}
void pushup(int i,int l,int r)
{
    if(cnt[i*2]==-1||cnt[i*2+1]==-1)
    cnt[i]=-1;
    else if(cnt[i*2]!=cnt[i*2+1])
    cnt[i]=-1;
    else
    cnt[i]=cnt[i*2];
    sum[i]=sum[i*2]+sum[i*2+1];
}
void build(int i,int l,int r)
{
    if(l==r)
    {
        cnt[i]=0;
        sum[i]=0.0;
        return ;
    }
    int m=(l+r)/2;
    build(lson);
    build(rson);
    pushup(i,l,r);
}
void update(int ql,int qr,int v,int i,int l,int r)
{
    if(ql<=l&&r<=qr)
    {
        if(cnt[i]!=-1)
        {
            cnt[i]+=v;
            sum[i]=(cnt[i]?(X[r+1]-X[l]):0);
            return ;
        }
    }
    pushdown(i,l,r);
    int m=(l+r)/2;
    if(ql<=m)
    update(ql,qr,v,lson);
    if(m<qr)
    update(ql,qr,v,rson);
    pushup(i,l,r);
}
int bin(double key,int n,double d[])
{
    int l=1,r=n;
    while(r>=l)
    {
        int m=(l+r)/2;
        if(d[m]==key)
        return m;
        else if(d[m]>key)
        r=m-1;
        else
        l=m+1;
    }
    return -1;
}
int main()
{
    int q;
    int w=0;
    while(scanf("%d",&q)&&q)
    {w++;

        double x1,y1,x2,y2;
    int n=0,m=0;
        for(int i=1;i<=q;i++)
        {scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
        X[++n]=x1;
        nodes[++m]=node(x1,x2,y1,1);
        X[++n]=x2;
        nodes[++m]=node(x1,x2,y2,-1);

        }
        sort(X+1,X+1+n);
        sort(nodes+1,nodes+m+1);
        int k=1;
        for(int i=2;i<=n;i++)
        if(X[i]!=X[i-1])
        X[++k]=X[i];
        build(1,1,k-1);
        double ret=0.0;
        for(int i=1;i<m;i++)
        {
            int l=bin(nodes[i].l,k,X);
            int r=bin(nodes[i].r,k,X)-1;
            if(l<=r)
            update(l,r,nodes[i].d,1,1,k-1);
            ret+=sum[1]*(nodes[i+1].h-nodes[i].h);
        }
         printf("Test case #%d\nTotal explored area: %.2lf\n\n",w,ret );
    }
    return 0;
}

代码2:固定cnt节点不往下传,只让它等于0或1,去掉pushdown

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define maxn 2500
#define lson i*2,l,m
#define rson i*2+1,m+1,r
double X[maxn];
struct node
{
    double l,r,h;
    int d;
    node()
    {

    }
    node(double a,double b,double c,int d):l(a),r(b),h(c),d(d) {}
    bool operator<(const node&b)const
    {
        return h<b.h;
    }
} nodes[maxn];
int cnt[maxn*4];
double sum[maxn*4];

void pushup(int i,int l,int r)
{
    if(cnt[i])
        sum[i]=X[r+1]-X[l];
    else if(l==r)
        sum[i]=0;
    else
        sum[i]=sum[i*2]+sum[i*2+1];
}

void update(int ql,int qr,int v,int i,int l,int r)
{
    if(ql<=l&&r<=qr)
    {

        cnt[i]+=v;
        pushup(i,l,r);
        return ;

    }

    int m=(l+r)>>1;
    if(ql<=m)
        update(ql,qr,v,lson);
    if(m<qr)
        update(ql,qr,v,rson);
    pushup(i,l,r);
}
int bin(double key,int n,double d[])
{
    int l=1,r=n;
    while(r>=l)
    {
        int m=(l+r)/2;
        if(d[m]==key)
            return m;
        else if(d[m]>key)
            r=m-1;
        else
            l=m+1;
    }
    return -1;
}
int main()
{
    int q;
    int w=0;
    while(scanf("%d",&q)&&q)
    {
        w++;

        double x1,y1,x2,y2;
        int n=0,m=0;
        for(int i=1; i<=q; i++)
        {
            scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
            X[++n]=x1;
            nodes[++m]=node(x1,x2,y1,1);
            X[++n]=x2;
            nodes[++m]=node(x1,x2,y2,-1);

        }
        sort(X+1,X+1+n);
        sort(nodes+1,nodes+m+1);
        int k=1;
        for(int i=2; i<=n; i++)
            if(X[i]!=X[i-1])
                X[++k]=X[i];
        memset(cnt,0,sizeof(cnt));
        memset(sum,0,sizeof(sum));
        double ret=0.0;
        for(int i=1; i<m; i++)
        {
            int l=bin(nodes[i].l,k,X);
            int r=bin(nodes[i].r,k,X)-1;
            if(l<=r)
                update(l,r,nodes[i].d,1,1,k-1);
            ret+=sum[1]*(nodes[i+1].h-nodes[i].h);
        }
        printf("Test case #%d\nTotal explored area: %.2lf\n\n",w,ret );
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdauguanweihong/article/details/83820602