POJ 1451 - T9 - [字典树]

题目链接:http://bailian.openjudge.cn/practice/1451/

总时间限制: 1000ms  内存限制: 65536kB

描述

Background

A while ago it was quite cumbersome to create a message for the Short Message Service (SMS) on a mobile phone. This was because you only have nine keys and the alphabet has more than nine letters, so most characters could only be entered by pressing one key several times. For example, if you wanted to type "hello" you had to press key 4 twice, key 3 twice, key 5 three times, again key 5 three times, and finally key 6 three times. This procedure is very tedious and keeps many people from using the Short Message Service.

This led manufacturers of mobile phones to try and find an easier way to enter text on a mobile phone. The solution they developed is called T9 text input. The "9" in the name means that you can enter almost arbitrary words with just nine keys and without pressing them more than once per character. The idea of the solution is that you simply start typing the keys without repetition, and the software uses a built-in dictionary to look for the "most probable" word matching the input. For example, to enter "hello" you simply press keys 4, 3, 5, 5, and 6 once. Of course, this could also be the input for the word "gdjjm", but since this is no sensible English word, it can safely be ignored. By ruling out all other "improbable" solutions and only taking proper English words into account, this method can speed up writing of short messages considerably. Of course, if the word is not in the dictionary (like a name) then it has to be typed in manually using key repetition again.

More precisely, with every character typed, the phone will show the most probable combination of characters it has found up to that point. Let us assume that the phone knows about the words "idea" and "hello", with "idea" occurring more often. Pressing the keys 4, 3, 5, 5, and 6, one after the other, the phone offers you "i", "id", then switches to "hel", "hell", and finally shows "hello".

Problem

Write an implementation of the T9 text input which offers the most probable character combination after every keystroke. The probability of a character combination is defined to be the sum of the probabilities of all words in the dictionary that begin with this character combination. For example, if the dictionary contains three words "hell", "hello", and "hellfire", the probability of the character combination "hell" is the sum of the probabilities of these words. If some combinations have the same probability, your program is to select the first one in alphabetic order. The user should also be able to type the beginning of words. For example, if the word "hello" is in the dictionary, the user can also enter the word "he" by pressing the keys 4 and 3 even if this word is not listed in the dictionary.

输入
The first line contains the number of scenarios.

Each scenario begins with a line containing the number w of distinct words in the dictionary (0<=w<=1000). These words are iven in the next w lines in ascending alphabetic order. Every line starts with the word which is a sequence of lowercase letters from the alphabet without whitespace, followed by a space and an integer p, 1<=p<=100, representing the probability of that word. No word will contain more than 100 letters.

Following the dictionary, there is a line containing a single integer m. Next follow m lines, each consisting of a sequence of at most 100 decimal digits 2?, followed by a single 1 meaning "next word".

输出
The output for each scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1.

For every number sequence s of the scenario, print one line for every keystroke stored in s, except for the 1 at the end. In this line, print the most probable word prefix defined by the probabilities in the dictionary and the T9 selection rules explained above. Whenever none of the words in the dictionary match the given number sequence, print "MANUALLY" instead of a prefix.

Terminate the output for every number sequence with a blank line, and print an additional blank line at the end of every scenario.

样例输入
2
5
hell 3
hello 4
idea 8
next 8
super 3
2
435561
43321
7
another 5
contest 6
follow 3
give 13
integer 6
new 14
program 4
5
77647261
6391
4681
26684371
77771

样例输出
Scenario #1:
i
id
hel
hell
hello

i
id
ide
idea


Scenario #2:
p
pr
pro
prog
progr
progra
program

n
ne
new

g
in
int

c
co
con
cont
anoth
anothe
another

p
pr
MANUALLY
MANUALLY

来源
Northwestern Europe 2001

题意:

原来的按键手机都一般是九键,九键输入英文很麻烦,例如要键入“hello”,必须按两次键4、两次键3、三次键5、三次键5,最后按三次键6。

现有一种新的输入方案名叫“T9”,只需要不重复地按键,软件就会使用内置的字典来查找最可能的与输入匹配的单词。例如,输入“hello”,只要依次按下4,3,5,5,6各一次即可。当然,这也可能是“gdjjm”一词的输入,但是因为这不是一个合理的英语单词,所以可以安全地忽略它。通过排除所有其他不可能的解决方案,并且只考虑适当的英语单词,这种方法可以大大加快短信的写作速度。当然,如果这个词不在软件内置的字典中(比如名字),那么它必须再次使用多次按键的方式输入。

现在给你“T9”的字典,包含 $w(0 \le w \le 1e3)$ 个互不相同的字符串(串长不超过 $100$,已经按字典序升序排序),以及他们的出现概率 $p$。又给出 $m$ 次打字操作,每次输入包含不超过 $100$ 个数字的 $2 \sim 9$ 数字串,代表依次按键,最后跟一个 $1$ 代表结束本次打字。

对“字符组合”的概率,定义为所有以该字符组合为前缀的单词的出现概率之和。例如,如果字典包含三个单词“hell”,“hello”和“hellfire”,则字符组合“hell”的概率是这些词的概率之和。如果某些组合具有相同的概率,则您的程序是选字典序最小的。

题解:

按照手机的 $2 \sim 9$ 八个数字键作为字典树每个节点的八个分支建树。

每个节点定义一个 $pr$ 和 $s$ 分别代表:按键按到当前位置,最有可能的是字符串 $s$,并且可能性为 $pr$。

这样一来,每次插入一个字符串,对每个节点均维护 $pr$ 和 $s$。

这样的话,不能分批次插入同一个前缀,一个前缀只能插入一次,因此不妨先把每个前缀的 $pr$ 求出来,由于输入的字典是按字典序排好序的,因此可以直接累加出前缀的最大概率。

这道题对于加深字典树的理解还是很有帮助的。

AC代码:

#include<bits/stdc++.h>
using namespace std;
const int maxn=1e3+5;
const int maxs=103;

int n,m;
string s[maxn];
int pr[maxn][maxs];

namespace Trie
{
    const int SIZE=maxn*maxs;
    int sz;
    struct TrieNode{
        int ed;
        string s;
        int pr;
        int nxt[8];
    }trie[SIZE];
    void init()
    {
        sz=1;
        for(int i=0;i<SIZE;i++)
        {
            trie[i].ed=trie[i].pr=0;
            trie[i].s.clear();
            memset(trie[i].nxt,0,sizeof(trie[i].nxt));
        }
    }
    const string key="22233344455566677778889999";
    void insert(int idx)
    {
        string &str=s[idx];
        int p=1;
        for(int k=0;k<str.size();k++)
        {
            int ch=key[str[k]-'a']-'2';
            if(!trie[p].nxt[ch]) trie[p].nxt[ch]=++sz;
            p=trie[p].nxt[ch];
            if(pr[idx][k]>trie[p].pr)
            {
                trie[p].pr=pr[idx][k];
                trie[p].s=str.substr(0,k+1);
            }
        }
        trie[p].ed++;
    }
    void search(const string& s)
    {
        int p=1;
        for(int i=0;i<s.size()-1;i++)
        {
            int ch=s[i]-'2';
            p=trie[p].nxt[ch];
            if(!p) cout<<"MANUALLY\n";
            else cout<<trie[p].s<<'\n';
        }
    }
};

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(nullptr);

    int T;
    cin>>T;
    for(int kase=1;kase<=T;kase++)
    {
        cin>>n;
        for(int i=1,prob;i<=n;i++)
        {
            cin>>s[i]>>prob;
            for(int k=0;k<s[i].size();k++) pr[i][k]=prob;
        }
        for(int i=2;i<=n;i++)
        {
            for(int k=0;k<min(s[i].size(),s[i-1].size());k++)
            {
                if(s[i][k]==s[i-1][k])
                {
                    pr[i][k]+=pr[i-1][k];
                    pr[i-1][k]=0;
                }
                else break;
            }
        }

        Trie::init();
        for(int i=1;i<=n;i++) Trie::insert(i);

        cin>>m;
        cout<<"Scenario #"<<kase<<":\n";
        for(int i=1;i<=m;i++)
        {
            cin>>s[0];
            Trie::search(s[0]);
            cout<<'\n';
        }
        cout<<'\n';
    }
}

注:

害怕cin/cout太慢,关闭IO同步并且解除cin/cout绑定,参考https://blog.csdn.net/qian2213762498/article/details/81982380

影响cout和cin的性能的有两个方面:同步性和缓冲区,同步性可以通过 ios::sync_with_stdio(false); 禁用;操作系统会对缓冲区进行管理和优化,但十分有限,使用了endl之后,会对缓冲区执行清空操作,这个过程会先执行’\n’,再执行flush操作,非常漫长,所以尽量使用‘\n’而不是endl执行换行。然后,还有一个cout和cin的绑定效果,两者同时使用的话,cin与cout交替操作,会有一个flush过程,所以还是会很漫长,可以通过 cin.tie(nullptr); 解除绑定。 

猜你喜欢

转载自www.cnblogs.com/dilthey/p/9937473.html
t9