POJ 2001 字典树

http://poj.org/problem?id=2001

Description

A prefix of a string is a substring starting at the beginning of the given string. The prefixes of "carbon" are: "c", "ca", "car", "carb", "carbo", and "carbon". Note that the empty string is not considered a prefix in this problem, but every non-empty string is considered to be a prefix of itself. In everyday language, we tend to abbreviate words by prefixes. For example, "carbohydrate" is commonly abbreviated by "carb". In this problem, given a set of words, you will find for each word the shortest prefix that uniquely identifies the word it represents. 

In the sample input below, "carbohydrate" can be abbreviated to "carboh", but it cannot be abbreviated to "carbo" (or anything shorter) because there are other words in the list that begin with "carbo". 

An exact match will override a prefix match. For example, the prefix "car" matches the given word "car" exactly. Therefore, it is understood without ambiguity that "car" is an abbreviation for "car" , not for "carriage" or any of the other words in the list that begins with "car". 

Input

The input contains at least two, but no more than 1000 lines. Each line contains one word consisting of 1 to 20 lower case letters.

Output

The output contains the same number of lines as the input. Each line of the output contains the word from the corresponding line of the input, followed by one blank space, and the shortest prefix that uniquely (without ambiguity) identifies this word.

Sample Input

carbohydrate
cart
carburetor
caramel
caribou
carbonic
cartilage
carbon
carriage
carton
car
carbonate

Sample Output

carbohydrate carboh
cart cart
carburetor carbu
caramel cara
caribou cari
carbonic carboni
cartilage carti
carbon carbon
carriage carr
carton carto
car car
carbonate carbona

题目大意:给出一些单词,让你按照输入顺序输出能代表该单词的最短前缀。(单词本身也是其前缀)

思路:字典树,我们用sum[i]表示以从字典树根节点0到节点i连成的字符串为前缀的单词个数,那么在查询一个单词的时候,在该路径的某个节点i出现了sum[i]=1的情况,就说明这个字符串是该单词的唯一前缀。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
#define INF 0x3f3f3f3f
using namespace std;

string s[1005];
int tree[150000][26];
int sum[150000];
int tot;

inline void Insert(int i)
{
	int len=s[i].size();
	int root=0;
	for(int j=0;j<len;j++)
	{
		int id=s[i][j]-'a';
		if(!tree[root][id])
			tree[root][id]=++tot;
		++sum[tree[root][id]];
		root=tree[root][id];
	}
}

inline void query(int i)
{
	int len=s[i].size();
	int root=0;
	for(int j=0;j<len;j++)
	{
		int id=s[i][j]-'a';
		root=tree[root][id];
		putchar(s[i][j]);
		if(sum[root]==1)
			break;
	}
	putchar('\n');
}

int main()
{
	int i=0;
	while(cin>>s[i++])
		Insert(i-1);
	for(int j=0;j<i;j++)
	{
		cout<<s[j]<<' ';
		query(j);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/xiji333/article/details/88760911