【二分】UVALive - 7261 A - Xiongnu's Land

A - Xiongnu's Land  UVALive - 7261 


Description Wei Qing (died 106 BC) was a military general of the Western Han dynasty whose campaigns against the Xiongnu earned him great acclaim. He was a relative of Emperor Wu because he was the younger half-brother of Empress Wei Zifu (Emperor Wu's wife) and the husband of Princess Pingyang. He was also the uncle of Huo Qubing, another notable Han general who participated in the campaigns against the Xiongnu and exhibited outstanding military talent even as a teenager.. Defeated by Wei Qing and Huo Qubing, the Xiongnu sang:“Losing my Qilian Mountains, made my cattle unthriving; Losing my Yanzhi Mountains, made my women lacking rouge.” 
 
The text above is digested from Wikipedia. Since Wei and Huo's distinguished achievements, Emperor Wu decided to give them some awards --- a piece of land taken by them from Xiongnu. This piece of land was located in a desert, and there were many oases in it. Emperor Wu wanted to draw a straight south-to-north dividing line to divide the land into two parts, and gave the western part to Wei Qing while gave the eastern part to Huo Qubing. There are two rules about the land dividing: 
 
1. The total area of the oases lay in Wei's land must be larger or equal to the total area of the oases lay in Huo's land, and the difference must be as small as possible. 2. Emperor Wu wanted Wei's land to be as large as possible without violating the rule 1.     To simplify the problem, please consider the piece of land given to Wei and Huo as a square on a plane. The coordinate of its left bottom corner was (0,0) and the coordinate of its right top corner was (R,R).  Each oasis in this land could also be considered as a rectangle which was parallel to the coordinate axes. The equation of the dividing line was like x = n, and n must be an integer. If the dividing line split an oasis, then Wei owned the western part and Huo owned the eastern part. Please help Emperor Wu to find out how to draw the dividing line. Input The first line of the input is an integer K meaning that there are K (1 <= K <=15) test cases. For each test case: The first line is an integer R, indicating that the land's right top corner was at (R,R) (1 < = R <= 1,000,000) Then a line containing an integer N follows, indicating that there were N (0 <N <= 10000) oases. Then N lines follow, each contains four integers  L,T, W and H, meaning that there was an oasis whose coordinate of the left top corner was (L,T), and its width was W and height was H. (0<=L,T <= R, 0<W,H <= R). No oasis overlaps.  
 
output

For each test case, print an integer n, meaning that Emperor Wu should draw a dividing line whose equation is x = n. Please note that, in order to satisfy the rules , Emperor might let Wei get the whole land by drawing a line of x = R if he had to.   Sample Input

2

1000

2

1 1 2 1

5 1 2 1

1000

1 1 1 2

1

Sample Output

5

有n个矩形,两两不重叠

给你一条竖直直线问你最大能放到几,让左边面积>=右边面积

#include <bits/stdc++.h>
#define ll long long
using namespace std;
const int maxn=1e5+10;
int n;
struct node
{
    ll x,y,c,k;
}a[maxn];

ll cal(ll x)
{
    ll area=0;
    for(int i=1;i<=n;i++)
    {
        if(a[i].x+a[i].c<=x)
            area+=a[i].c*a[i].k;
        else
        {
            if(a[i].x>=x) continue;
            area+=(x-a[i].x)*a[i].k;
        }
    }
    return area;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        ll sum=0;
        int l=0,R;
        scanf("%d%d",&R,&n);
        int r=R;
        for(int i=1;i<=n;i++)
        {
            scanf("%lld%lld%lld%lld",&a[i].x,&a[i].y,&a[i].c,&a[i].k);
            sum+=a[i].c*a[i].k;
        }
        while(l<=r)
        {
            int mid=(l+r)/2;
            ll area=cal(mid);
            if(area*2<sum) l=mid+1;
            else r=mid-1;
        }
        ll temp=cal(l);
        while(cal(l)==temp&&l<=R) l++;  //不写l<=R 就TLE
        printf("%d\n",l-1);
    }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/qq_41037114/article/details/82987759