C++ algorithm 头文件 定义的 sort() 实现绝对值排序

Problem Description

输入n(n<=100)个整数,按照绝对值从大到小排序后输出。题目保证对于每一个测试实例,所有的数的绝对值都不相等。

Input

输入数据有多组,每组占一行,每行的第一个数字为n,接着是n个整数,n=0表示输入数据的结束,不做处理。

Output

对于每个测试实例,输出排序后的结果,两个数之间用一个空格隔开。每个测试实例占一行。

Sample Input

3  3  -4  2
4  0   1  2  -3
0

Sample Output

-4 3 2
-3 2 1 0

这题用普通的冒泡排序等初等排序容易超时,自己去定义快排,归并排序等高级排序又过于复杂且很难速度比C++自带的的sort函数快,所以建议就用sort()函数。

参考代码如下:

#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

bool cmp (const int a, const int b);

int main()
{
    int n;
    while (cin >> n && n!=0)
    {
        int a[100];
        for (int i = 0; i<n; i++)
            cin >> a[i];
        sort(a, a+n, cmp);
        for(int i = 0; i<n; i++)
        {
            if (i)
                cout << " ";
            cout << a[i];
        }
        cout << endl;
    }
}
bool cmp (const int a, const int b)
{
    return abs(a) > abs(b);
}

sort()函数的参数列表可以有参数可以有两个,有三个;

两个参数的 如:
int a[4] = {1, 3, 5, 2};
sort(a, a+4);
第一个参数是数组首地址, 第二个参数是数组末尾地址的后面一个地址,默认升序排列;两个参数想要完成降序排列可以将数组内的数全部加上 “-” 号,变成相反数排序后再加上 “-” 输出;

三个参数的 就像上面的题解参考代码了:
第三个参数是 bool 类型,可以理解为排序的方式;

更多请见 https://blog.csdn.net/w_linux/article/details/76222112

猜你喜欢

转载自blog.csdn.net/weixin_43469047/article/details/83577672
今日推荐