Problem Preparation(POJ)

                                             Problem Preparation

It's time to prepare the problems for the 14th Zhejiang Provincial Collegiate Programming Contest! Almost all members of Zhejiang University programming contest problem setter team brainstorm and code day and night to catch the deadline, and empty bottles of Marjar Cola litter the floor almost everywhere!

To make matters worse, one of the team member fell ill just before the deadline. So you, a brilliant student, are found by the team leader Dai to help the team check the problems' arrangement.

Now you are given the difficulty score of all problems. Dai introduces you the rules of the arrangement:

  1. The number of problems should lie between 10 and 13 (both inclusive).
  2. The difficulty scores of the easiest problems (that is to say, the problems with the smallest difficulty scores) should be equal to 1.
  3. At least two problems should have their difficulty scores equal to 1.
  4. After sorting the problems by their difficulty scores in ascending order, the absolute value of the difference of the difficulty scores between two neighboring problems should be no larger than 2. BUT, if one of the two neighboring problems is the hardest problem, there is no limitation about the difference of the difficulty scores between them. The hardest problem is the problem with the largest difficulty score. It's guaranteed that there is exactly one hardest problem.

The team members have given you lots of possible arrangements. Please check whether these arrangements obey the rules or not.

Input

There are multiple test cases. The first line of the input is an integer T (1 ≤ T ≤ 104), indicating the number of test cases. Then T test cases follow.

The first line of each test case contains one integer n (1 ≤ n ≤ 100), indicating the number of problems.

The next line contains n integers s1, s2, ... , sn (-1000 ≤ si ≤ 1000), indicating the difficulty score of each problem.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each test case, output "Yes" (without the quotes) if the arrangement follows the rules, otherwise output "No" (without the quotes).

扫描二维码关注公众号,回复: 3843306 查看本文章

Sample Input

8
9
1 2 3 4 5 6 7 8 9
10
1 2 3 4 5 6 7 8 9 10
11
999 1 1 2 3 4 5 6 7 8 9
11
999 1 3 5 7 9 11 13 17 19 21
10
15 1 13 17 1 7 9 5 3 11
13
1 1 1 1 1 1 1 1 1 1 1 1 2
10
2 3 4 5 6 7 8 9 10 11
10
15 1 13 3 6 5 4 7 1 14

Sample Output

No
No
Yes
No
Yes
Yes
No
No

Hint

The first arrangement has 9 problems only, which violates the first rule.

Only one problem in the second and the fourth arrangement has a difficulty score of 1, which violates the third rule.

The easiest problem in the seventh arrangement is a problem with a difficulty score of 2, which violates the second rule.

After sorting the problems of the eighth arrangement by their difficulty scores in ascending order, we can get the sequence 1, 1, 3, 4, 5, 6, 7, 13, 14, 15. We can easily discover that |13 - 7| = 6 > 2. As the problem with a difficulty score of 13 is not the hardest problem (the hardest problem in this arrangement is the problem with a difficulty score of 15), it violates the fourth rule.

题目链接:

https://vjudge.net/problem/ZOJ-3959

题意描述:

给你n个数,有以下几种规定,如果n小于10或者大于13就输出No,如果这些数字排序后前两个数不是1也输出No,如果数字之间的差大于2也输出No(最后一个数与倒数第二个数的差没限制),其他情况输出Yes

解题思路:

定义一个数组,里面存n个数,首先判断a[0]和a[1]是否都为0,然后让两两相减,除了最后一个数与第一个数不相减,判断两两相减的差是否大于2

程序代码:

#include<stdio.h>
#include<algorithm>
using namespace std;
int a[110];

int main()
{
	int i,T,n,flag;
	
	scanf("%d",&T);
	while(T--)
	{
		flag=0;
		scanf("%d",&n);
		if(n<10||n>13)
		{
			for(i=0;i<n;i++)
				scanf("%d",&a[i]);
			printf("No\n");
		}
		else
		{
			for(i=0;i<n;i++)
				scanf("%d",&a[i]);
			sort(a,a+n);
			if(a[0]!=1||a[1]!=1)
			{
				printf("No\n");
				flag=1;
			}
			else
			{
				for(i=1;i<n-2;i++)
					if(a[i+1]-a[i]>2)
					{
						printf("No\n");
						flag=1;
						break;
					}
			}
			if(flag==0)
				printf("Yes\n");
		}	
	}
    return 0;
}

猜你喜欢

转载自blog.csdn.net/HeZhiYing_/article/details/83350464