PTA 7-1 Huffman Codes (30 分)

版权声明:勿转 https://blog.csdn.net/wuqi5328/article/details/83215580

7-1 Huffman Codes (30 分)

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <string.h>
#include <string>
#include <iostream>
using namespace std;
typedef struct LNode{
    char name;
    int weight;
    int parent;
}LNode;
void Select_min2(LNode * hf,int end,int &min1,int &min2){
    for(int i=0;i<end;i++){
        if(hf[i].parent==-1){
            min1=i;break;
        }
    }
    for(int i=0;i<end;i++){
        if(hf[i].parent==-1&&i!=min1){
            min2=i;break;
        }
    }
    if(hf[min1].weight>hf[min2].weight){
        int temp=min1;
        min1=min2;
        min2=temp;
    }
    for(int i=0;i<end;i++){
        if(hf[i].parent==-1){
            if(hf[i].weight<hf[min1].weight&&i!=min1&&i!=min2){
                int temp=min1;
                min1=i;
                min2=temp;
            }
            else if(hf[i].weight>=hf[min1].weight&&hf[i].weight<hf[min2].weight&&i!=min1&&i!=min2){
                min2=i;
            }
        }
    }
}
int GetWeight(LNode *hf,char ch,int num){
    for(int i=0;i<num;i++){
        if(hf[i].name==ch)
            return hf[i].weight;
    }
}
int main(){
    int num;scanf("%d",&num);

    LNode *hf=(LNode *)malloc(sizeof(LNode)*(2*num));
    for(int i=0;i<num;i++){
        getchar();
        scanf("%c %d",&hf[i].name,&hf[i].weight);
        hf[i].parent=-1;
    }
    int min1,min2;
    int WPL=0;
    for(int i=num;i<2*num-1;i++){
        Select_min2(hf,i,min1,min2);
        hf[i].weight=hf[min1].weight+hf[min2].weight;
        hf[min1].parent=i;
        hf[min2].parent=i;
        WPL+=hf[i].weight;
        hf[i].parent=-1;
    }
    int num2;scanf("%d",&num2);
    while(num2--){
        string code[1005];
        int sum=0;
        for(int i=0;i<num;i++){
            getchar();
            char ch;
            cin>>ch>>code[i];
            int len=code[i].length(),weight;
            weight=GetWeight(hf,ch,num);
            sum+=weight*len;
        }
        if(sum!=WPL){
            printf("No\n");
        }
        else {//判断前缀码
                int flag=0;
            for(int i=0;i<num;i++){

                int len=code[i].length();
                for(int k=0;k<num;k++){
                    if(k!=i){
                        int len1=code[k].length();
                        if(len<=len1){
                            if(code[i]==code[k].substr(0,len)) {
                                    flag=1;
                                    break;
                            }
                        }
                    }
                }
                if(flag) break;
            }
            if(flag) printf("No\n");
            else printf("Yes\n");
        }
    }
}

猜你喜欢

转载自blog.csdn.net/wuqi5328/article/details/83215580