nyoj269VF

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qjt19950610/article/details/47087107


/*VF
时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to
the science and to become famous all over the world. But how can he do that
if the most interesting facts such as Pythagor’s theorem are already proved?
Correct! He is to think out something his own, original.
So he thought out the Theory of Vasya’s Functions.
Vasya’s Functions (VF) are rather simple: the value of the Nth VF in the point S is
an amount of integers from 1 to N that have the sum of digits S.
You seem to be great programmers, so Vasya gave you a task to find the milliard VF
value (i.e. the VF with N = 109) because Vasya himself won’t cope with the task.
Can you solve the problem?

输入There are multiple test cases.
 Integer S (1 ≤ S ≤ 81).输出The milliard VF value in the point S.样例输入1
样例输出10*/

<span style="font-size:18px;">#include <stdio.h>   
int dp[10][82];  
  
void func()  
{  
    int i,j,k;  
    for(i = 1; i < 10; i++)  
    {  
        dp[1][i] = 1;  
    }  
    for(i = 2; i < 10; i++)  
    {  
        for(j = 1; j <= 9*i; j++)  
        {  
            for(k = 0; k <= 9&&k < j; k++)  
            {  
                dp[i][j] += dp[i-1][j-k];  
            }  
        }  
    }  
}  
int main()  
{  
    int s,i;  
    func();  
    while(~scanf("%d",&s))  
    {  
        int count = 0;  
        if(s == 1)  
        {  
            printf("%d\n",10);  
            continue;  
        }  
        else  
        {  
            for(i = 1; i < 10; i++)              {  
                count += dp[i][s];  
            }  
        }  
        printf("%d\n",count);  
    }  
    return 0;  
} 
</span>

猜你喜欢

转载自blog.csdn.net/qjt19950610/article/details/47087107