Mincost

The cost of taking a taxi in Hangzhou is not a constant for each kilometer you travel: the first 4 kilometers costs 10 yuan (yuan is the monetary unit in China), even if you don't finish it; the next 4 kilometers costs 2 yuan each and the price for the rest of the trip is 2.4 yuan per kilometer; the last part of the trip is regarded as 1 kilometer even if it's shorter. A traveller may reduce the cost by reseting the meter at the middle of the trip if used wisely. For example, if the trip is 16 kilometers, he should cut it into two parts with the same length, each half will cost 18 yuan, with an overall cost of 36, less than the original price of 37.2. Now, given the length of the trip, find the minimum cost.

输入

The input contains several cases, each has one positive integer in a seperate line, representing the length of the trip. All input data are less than 10000000. Proceed until a case with zero, which should be ignored.

输出

For each case, output the minimum cost, leave one digit after decimal point if NECESSARY.

样例输入

3
9
16
0

样例输出

10
20.4
36
#include<stdio.h>  
#include<math.h>  
#include<string.h>  
int main()  
{  
    //freopen("input.txt","r",stdin)  
    double ans;int f;  
    while(~scanf("%d",&f)&&f)  
    {  
        ans=0;  
        if(f>0&&f<4)ans=10;  
        else if(f>=4&&f<=8)ans=2+2*f;  
        else  
        {  
            int k=f%8;  
            ans=18*(f-k)/8;  
            if(k<5)  
             ans+=k*2.4;  
            else  
                ans+=10+(k-4)*2;  
        }  
        printf("%g\n",ans);  
    }  
    return 0;  
} 

猜你喜欢

转载自www.cnblogs.com/Lazy-Cat/p/9838131.html