Assign the task HDU - 3974 (dfs序+线段树)

版权声明:本文为博主瞎写的,请随便转载 https://blog.csdn.net/sdut_jk17_zhangming/article/details/83187603

There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree. 

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one. 

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.

Input

The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases. 

For each test case: 

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees. 

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N). 

The next line contains an integer M (M ≤ 50,000). 

The following M lines each contain a message which is either 

"C x" which means an inquiry for the current task of employee x 

or 

"T x y"which means the company assign task y to employee x. 

(1<=x<=N,0<=y<=10^9)

Output

For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3

Sample Output

Case #1:
-1 
1 
2

题意

给您一个数,两种操作(1) 查询x的颜色(2)把x节点即子节点染成y

思路

先用dfs序建立线段树,区间修改单点查询

#include <bits/stdc++.h>

using namespace std;
const int maxn = 5e4+7;
int n,m;
vector<int> adj[maxn];
int len[maxn],tree[maxn],lazy[maxn<<2],a[maxn];
bool vis[maxn];
int dfs(int u)
{
    tree[u]=++m;
    int res=1;
    for(int i=0;i<adj[u].size();i++)
    {
        int v = adj[u][i];
        if(vis[v]) continue;
        vis[v] = true;
        res += dfs(v);
    }
    return len[u] = res;
}
void push_down(int now)
{
    if(lazy[now] == -1) return ;
    lazy[now<<1] = lazy[now<<1|1] = lazy[now];
    lazy[now] = -1;
}
void updata(int now,int l,int r,int ul,int ur,int t)
{
    if(ul<=l&&ur>=r)
    {
        lazy[now] = t;
        return ;
    }
    push_down(now);
    int m = (l+r)>>1;
    if(ul <= m) updata(now<<1,l,m,ul,ur,t);
    if(ur > m) updata(now<<1|1,m+1,r,ul,ur,t);
}
int query(int now,int l,int r,int p)
{
    if(l==r) return lazy[now];
    int m = (l+r)>>1;
    push_down(now);
    if(p<=m) return query(now<<1,l,m,p);
    else return query(now<<1|1,m+1,r,p);
}

int main()
{
    int t,i,j;
    scanf("%d",&t);
    int ca=1;
    while(t--)
    {
        scanf("%d",&n);
        int u,v;
        for(i=1;i<=n;i++) adj[i].clear();
        memset(a,0,sizeof(a));
        memset(len,0,sizeof(len));
        for(i=1;i<n;i++)
        {
            scanf("%d%d",&u,&v);
            adj[v].push_back(u);
            a[u]++;
        }
        for(i=1;i<=n;i++)
        {
            if(!a[i])
            {
                m = 0;
                memset(vis,false,sizeof(vis));
                dfs(i);
                break;
            }
        }
        memset(lazy,-1,sizeof(lazy));
        scanf("%d",&m);
        char option[3];
        printf("Case #%d:\n",ca++);
        for(i=0;i<m;i++)
        {
            scanf("%s",option);
            if(option[0]=='C')
            {
                scanf("%d",&u);
                printf("%d\n",query(1,1,n,tree[u]));
            }
            else
            {
                scanf("%d%d",&u,&v);
                updata(1,1,n,tree[u],tree[u]+len[u]-1,v);
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/sdut_jk17_zhangming/article/details/83187603
今日推荐