HDU - 3974 Assign the task【dfs序+线段树】

Assign the task

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4685    Accepted Submission(s): 1870


Problem Description
There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.
 

Input
The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)
 

Output
For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.
 

Sample Input
 
  
1 5 4 3 3 2 1 3 5 2 5 C 3 T 2 1 C 3 T 3 2 C 3
 

Sample Output
 
  
Case #1: -1 1 2
 

Source
 

Recommend
 

思路:

模板题。dfs序+线段树维护。

dfs序需要用一个数组记录dfs序,再用一个数组记录一个节点在dfs序中的下标,再用一个数组记录dfs序中当前节点所管辖的区间右边界。


代码:

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<algorithm>
#include<vector>
#include<queue>
#include<set>
using namespace std;
#define inf 0x3f3f3f3f
#define MAXN 50005
#define ll long long
int n,m,laz[MAXN*4],ord[MAXN*4],root,tot,tmp[MAXN*4],ed[MAXN*4];
bool haspre[MAXN];
vector<int> vec[MAXN];
void dfs(int u)
{
    tmp[u]=++tot;
    ord[tot]=u;
    for(int i=0;i<vec[u].size();i++)
    {
        int v=vec[u][i];
        dfs(v);
    }
    ed[u]=tot;
}
void pushdown(int v)
{
    laz[v*2]=laz[v];
    laz[v*2+1]=laz[v];
    laz[v]=-1;
}
void updata(int v,int L,int R,int ql,int qr,int d)
{
    if(ql<=L && R<=qr)
    {
        laz[v]=d;
        return;
    }
    if(laz[v]!=-1) pushdown(v);
    int mid=(L+R)/2;
    if(ql<=mid) updata(v*2,L,mid,ql,qr,d);
    if(qr>mid) updata(v*2+1,mid+1,R,ql,qr,d);
}
int query(int v,int L,int R,int q)
{
    if(L==R) return laz[v];
    if(laz[v]!=-1) pushdown(v);
    int mid=(L+R)/2;
    if(q<=mid) return query(v*2,L,mid,q);
    else return query(v*2+1,mid+1,R,q);
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int tt=1;tt<=t;tt++)
    {
        printf("Case #%d:\n",tt);
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            vec[i].clear();
        memset(haspre,0,sizeof haspre);
        for(int i=1;i<n;i++)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            vec[v].push_back(u);
            haspre[u]=1;
        }
        for(int i=1;i<=n;i++)
            if(!haspre[i])
        {
            root=i;
            break;
        }
        tot=0;
        memset(tmp,0,sizeof tmp);
        dfs(root);
        memset(laz,-1,sizeof laz);
        char op[2];
        int u;
        scanf("%d",&m);

        while(m--)
        {
            scanf("%s",op);
            if(op[0]=='C')
            {
                scanf("%d",&u);
                printf("%d\n",query(1,1,tot,tmp[u]));
            }
            else if(op[0]=='T')
            {
                int d;
                scanf("%d%d",&u,&d);
                updata(1,1,tot,tmp[u],ed[u],d);
            }
        }
    }
	return 0;
}

猜你喜欢

转载自blog.csdn.net/u013852115/article/details/80577560
今日推荐