java—学生类

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/qq_42623428/article/details/83181609

Description

有一个学生类的结构如下:
class Student {
	private int no;
	private String name;
        private int score;
	
	public Student(int _no, String _name, int _score) {
		no = _no;
		name = _name;
                score = _score;
	}
        public int getNo() {return no;}
        public String getName() {return name;}
        public int getScore() {return score;}
	
	public void print(){
		System.out.println(no + " "+name+" "+score);
	}
}

请构造main函数完成如下功能:
从键盘中读入三个学生的信息,比较他们的成绩,按照成绩由高到低排列输出

Input

三个学生的学号、姓名、成绩

Output

由高到低排列输出的三个学生信息

Sample Input

1 wang 89
2 liu 78
3 ma 90

Sample Output

3 ma 90
1 wang 89
2 liu 78
import java.util.*;

public class Main {

    public static void main(String[] args) {

        Scanner input=new Scanner(System.in);

        Student s[]=new Student[4];

        for(int i=0;i<3;i++) {

            int a=input.nextInt();

            String n =input.next();

            int b=input.nextInt();

            s[i]=new Student(a,n,b);

        }

        for(int i=0;i<=2;i++) {

            for(int j=i+1;j<3;j++)

            if(s[i].getScore()<s[j].getScore()) {

                Student ss=new Student(0,"",0);

                ss=s[i];

                s[i]=s[j];

                s[j]=ss;

            }

        }

        for(int i=0;i<=2;i++) {

            s[i].print();

        }

    }

}

猜你喜欢

转载自blog.csdn.net/qq_42623428/article/details/83181609