HDU 3488 Tour 有向环最小权值覆盖 最小费用最大流

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/Tawn0000/article/details/82851868
 

                                                 Tour

                                          Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
                                                               Total Submission(s): 4178    Accepted Submission(s): 1996


 

Problem Description

In the kingdom of Henryy, there are N (2 <= N <= 200) cities, with M (M <= 30000) one-way roads connecting them. You are lucky enough to have a chance to have a tour in the kingdom. The route should be designed as: The route should contain one or more loops. (A loop is a route like: A->B->……->P->A.)
Every city should be just in one route.
A loop should have at least two cities. In one route, each city should be visited just once. (The only exception is that the first and the last city should be the same and this city is visited twice.)
The total distance the N roads you have chosen should be minimized.

 

Input

An integer T in the first line indicates the number of the test cases.
In each test case, the first line contains two integers N and M, indicating the number of the cities and the one-way roads. Then M lines followed, each line has three integers U, V and W (0 < W <= 10000), indicating that there is a road from U to V, with the distance of W.
It is guaranteed that at least one valid arrangement of the tour is existed.
A blank line is followed after each test case.

 

Output

For each test case, output a line with exactly one integer, which is the minimum total distance.

 

Sample Input

 
1
6 9
1 2 5
2 3 5
3 1 10
3 4 12
4 1 8
4 6 11
5 4 7
5 6 9
6 5 4
 

Sample Output

 

42

 

Source

2010 ACM-ICPC Multi-University Training Contest(6)——Host by BIT


【题解】求哈密顿环最小覆盖边权和

  #include <bits/stdc++.h>

  using namespace std;
  const int maxn = 450;
  const int maxm = 100 + 100;
  const int INF = 0x3f3f3f3f;
  typedef long long LL;
  typedef pair<int,int> P;
  //const LL mod = 1e9 + 7;

  #define PI 3.1415926
  #define sc(x)  scanf("%d",&x)
  #define pf(x)  printf("%d",x)
  #define pfn(x) printf("%d\n",x)
  #define pfln(x) printf("%lld\n",x)
  #define pfs(x) printf("%d ",x)
  #define rep(n) for(int i = 0; i < n; i++)
  #define per(n) for(int i = n-1; i >= 0; i--)
  #define mem(a,x) memset(a,x,sizeof(a))


  int n,m;

  struct edge
  {
    int from,to,cap,flow,cost;
    edge(int from,int to, int cap, int flow, int cost) : from(from),to(to),cap(cap),flow(flow),cost(cost) {}
  };

  int tot = 0;
  vector<edge> E;
  vector<int> G[maxn];
  int inq[maxn];
  int d[maxn];
  int p[maxn];
  int a[maxn];


  void add_edge(int from, int to, int cap, int cost)
  {
    E.push_back(edge(from,to,cap,0,cost));
    E.push_back(edge(to,from,0,0,-cost));
    tot = E.size();
    G[from].push_back(tot-2);
    G[to].push_back(tot-1);
  }

  bool spfa(int s, int t, int &flow, int &cost)
  {
    mem(d,INF);
    mem(inq,0);
    d[s] = 0,inq[s] = 1; p[s] = 0, a[s] = INF;
    queue<int> Q;
    Q.push(s);
    while(!Q.empty())
    {
      int u = Q.front();Q.pop();
      inq[u] = 0;
      for(int i = 0; i < G[u].size(); i++)
      {
        edge e = E[G[u][i]];
        if(e.cap > e.flow && d[e.to] > d[u] + e.cost)
        {
          d[e.to] = d[u] + e.cost;
          p[e.to] = G[u][i];
          a[e.to] = min(a[u],e.cap - e.flow);
          if(!inq[e.to]) {Q.push(e.to); inq[e.to] = 1;}
        }
      }
    }

    if(d[t] == INF) return false;
    flow += a[t];
    cost += d[t] * a[t];
    int u = t;
    while(u != s)
    {
      E[p[u]].flow += a[t];
      E[p[u]^1].flow -= a[t];
      u = E[p[u]].from;
    }
    return true;
  }

  int mcf(int s, int t)
  {
    int flow = 0,cost = 0;
    while(spfa(s,t,flow,cost)) ;
  	//cout << flow << endl;
    return cost;
  }

  int hx[105],hy[105];
  int mx[105],my[105];
  int htot = 0, mtot = 0;

  void input()
  {
  	getchar();
  	for(int i = 0; i < n; i++)
  	  {
  			for(int j = 0; j < m; j++)
  		   {
  				 char c;
  				 scanf("%c",&c);
  				 if(c == 'H')
  				    hx[++htot] = i,hy[htot] = j;
  				 if(c == 'm')
  				    mx[++mtot] = i,my[mtot] = j;
  			 }
  			 getchar();
  		 }
  }

  int main()
  {
  	 int T;
     int s,t;
     sc(T);
  	 while(T--)
  	 {
     sc(n);sc(m);
  	 s = 0;t = 2*n+1;
  	 E.clear();
  	 tot = 0;
  	 for(int i = 0; i <= t; i++) G[i].clear();
  	 for(int i = 1; i <= n; i++) {add_edge(s,i,1,0);add_edge(i+n,t,1,0);}
  	 for(int i = 0; i < m; i++)
  	  {
  			int u,v,c;
  			sc(u);sc(v);sc(c);
  			add_edge(u,v+n,1,c);
  		}
  	 pfn(mcf(s,t));
   }
   return 0;
  }

猜你喜欢

转载自blog.csdn.net/Tawn0000/article/details/82851868