中医药院校程序设计竞赛备赛一-Problem B: Amity Assessment(二维转一维)

Problem B: Amity Assessment

Time Limit: 2 Sec  Memory Limit: 256 MB
Submit: 68  Solved: 27
[Submit][Status][Web Board]

Description

Bessie the cow and her best friend Elsie each received a sliding puzzle on Pi Day. Their puzzles consist of a 2×2 grid and three tiles labeled 'A', 'B', and 'C'. The three tiles sit on top of the grid, leaving one grid cell empty. To make a move, Bessie or Elsie can slide a tile adjacent to the empty cell into the empty cell as shown below:

In order to determine if they are truly Best Friends For Life (BFFLs), Bessie and Elsie would like to know if there exists a sequence of moves that takes their puzzles to the same configuration (moves can be performed in both puzzles). Two puzzles are considered to be in the same configuration if each tile is on top of the same grid cell in both puzzles. Since the tiles are labeled with letters, rotations and reflections are not allowed.

Input

 The first two lines of the input consist of a 2×2 grid describing the initial configuration of Bessie's puzzle. The next two lines contain a 2×2 grid describing the initial configuration of Elsie's puzzle. The positions of the tiles are labeled 'A', 'B', and 'C', while the empty cell is labeled 'X'. It's guaranteed that both puzzles contain exactly one tile with each letter and exactly one empty position.

Output

 Output "YES"(without quotes) if the puzzles can reach the same configuration (and Bessie and Elsie are truly BFFLs). Otherwise, print "NO" (without quotes).

Sample Input

AB XC XB AC

Sample Output

YES

HINT

The solution to the sample is described by the image. All Bessie needs to do is slide her 'A' tile down. 

2*2的华容道,只有一个空格,所以只能顺时针或逆时针移动,要判断题中给出的A状态是否能转换到B状态,就是看A状态顺时针移动(或逆时针)能否到达B状态,所以就把A状态下2*2的格子掰直成字符串,因为要循环所以用两段字符串相连来表示。

#include<cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
char a[10][10],b[10][10];
int main()
{
    string s,s2;
    for(int i = 0 ; i < 2;i++)
    {
        for(int j = 0 ;j < 2;j ++)
            cin>>a[i][j];
    }
    if(a[0][0] != 'X')
        s += a[0][0];
    if(a[0][1] != 'X')
        s += a[0][1];
    if(a[1][1] != 'X')//注意顺序是先a[1][1]再a[1][0],因为我假设顺时针方向移动的
        s += a[1][1];
    if(a[1][0] != 'X')
        s += a[1][0];
    s = s + s;
    for(int i = 0 ; i < 2;i++)
    {
        for(int j = 0 ;j < 2;j ++)
            cin>>b[i][j];
    }
    if(b[0][0] != 'X')
        s2 += b[0][0];
    if(b[0][1] != 'X')
        s2 += b[0][1];
    if(b[1][1] != 'X')
        s2 += b[1][1];
    if(b[1][0] != 'X')
        s2 += b[1][0];
    if(s.find(s2) != string::npos)
        cout<<"YES"<<endl;
    else
        cout<<"NO"<<endl;
   
    return 0;
}

猜你喜欢

转载自blog.csdn.net/hzyhfxt/article/details/82862968