hdu 5532 Almost Sorted Array (水题)

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 8541    Accepted Submission(s): 1982


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array  a1,a2,,an, is it almost sorted?
 
Input
The first line contains an integer  T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000
 
Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 
Sample Input
3 3 2 1 7 3 3 2 1 5 3 1 4 1 5
 
Sample Output
YES YES NO
 
 
 

 
题目大意:
给你一个数列,请你判断是不是almost sorted了。almost sorted意味着,从该数列中最多拿走一个数,这个数列就变成有序的了。
 
水题。
有一些坑点吧。要考虑仔细了。
拿判断是否上升almost sorted来说。最多只能有一个下降的点。比方说a[i]<a[i-1],这时候有两种删点的可能,一种是a[i],一种是a[i-1]。两种只要一种满足就行。
 
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

const int maxn=100000;

int a[maxn+5];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",a+i);

        bool flag1=true,flag2=true;

        for(int i=2,j=0;i<=n;i++)
        {
            if(a[i]<a[i-1])
                j++;
            if(j==2)
            {
                flag1=false;
                break;
            }
        }
        if(flag1)
        {
            for(int i=2;i<=n;i++)
            {
                if(a[i]<a[i-1])
                {
                    if(i!=n&&a[i+1]<a[i-1]&&i-1!=1&&a[i-2]>a[i])
                        flag1=false;
                    break;
                }
            }
        }

        for(int i=2,j=0;i<=n;i++)
        {
            if(a[i]>a[i-1])
                j++;
            if(j==2)
            {
                flag2=false;
                break;
            }
        }
        if(flag2)
        {
            for(int i=2;i<=n;i++)
            {
                if(a[i]>a[i-1])
                {
                    if(i!=n&&a[i+1]>a[i-1]&&i-1!=1&&a[i-2]<a[i])
                        flag2=false;
                    break;
                }
            }
        }

        if(flag1||flag2)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
View Code

猜你喜欢

转载自www.cnblogs.com/acboyty/p/9751105.html
今日推荐