1132 Cut Integer

1132 Cut Integer
Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2
​31
​​ ). It is guaranteed that the number of digits of Z is an even number.

Output Specification:
For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:
3
167334
2333
12345678
Sample Output:
Yes
No
No

#include<iostream>
#include<string>
using namespace std;
bool func(string s) {
	int k = s.size(), a, n, m;
	string s1 = s.substr(0, k / 2), s2 = s.substr(k / 2, k / 2);
	n = stoi(s1); m = stoi(s2);
	a = stoi(s);
	if (n == 0 || m == 0)return false;
	if (a%n == 0 && a / n % m == 0)return true;
    return false;
}
int main() {
	int n;
	string s;
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> s;
		if (func(s))cout << "Yes" << endl;
		else cout << "No" << endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ssf_cxdm/article/details/82951223
今日推荐