最短路-------K - Candies

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input
The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output
Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input
2 2
1 2 5
2 1 4
Sample Output
5
Hint
32-bit signed integer type is capable of doing all arithmetic.

典型的差分约束系统,对于a - b <= k的约束,求最大值,应该以b -> a = k建图求最短路。。
但是spfa + queue会超,不知道为啥用栈可以过。。。。。
spfa + 栈 + vector还是会超,然后换前向星数组才A
vector动态数组是真的慢,怪不得好多大佬的代码里用vector的比较少。。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<queue>
#include<stack>
using namespace std;
typedef long long LL;
const int inf = 0x3f3f3f3f;
const double eps = 1e-8;
const double PI = acos(-1);
#define pb push_back
#define mp make_pair
#define fi first
#define se second
const int N = 3 * 1e4 + 5;

int n,m;
LL dis[N];
bool vis[N];
int cnt = 0;
typedef struct Edge{
    int u,v,w,nxt;
}Edge;
Edge edge[150000 + 10];
int head[N];

void addEdge(int u,int v,int w)
{
    edge[cnt].u = u;
    edge[cnt].v = v;
    edge[cnt].w = w;
    edge[cnt].nxt = head[u];
    head[u] = cnt++;
}

void spfa()
{
    memset(vis,false,sizeof(vis));
    memset(dis,inf,sizeof(dis));
    stack<int>que;
    vis[1] = true;
    dis[1] = 0;
    que.push(1);
    while(!que.empty())
    {
        int tmp = que.top();
        que.pop();
        vis[tmp] = false;
        for(int i = head[tmp];i != -1;i = edge[i].nxt){
            int to = edge[i].v;
            int val = edge[i].w;
            if(dis[tmp] + val < dis[to]){
                dis[to] = dis[tmp] + val;
                if(!vis[to]){
                    vis[to] = true;
                    que.push(to);
                }
            }
        }
    }
}

int main()
{
    while(~scanf("%d %d",&n,&m))
    {
       memset(head,-1,sizeof(head));
       cnt = 0;
       for(int i = 0;i < m;++i){
            int a,b,c;
            scanf("%d %d %d",&a,&b,&c);
            addEdge(a,b,c);
       }
       spfa();
       printf("%lld\n",dis[n]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36386435/article/details/82943020