[洛谷]P1535 游荡的奶牛 (#搜索 -2.7)

版权声明:JCBP工作室 & A.pro https://blog.csdn.net/Apro1066/article/details/82766002

题目描述

Searching for the very best grass, the cows are travelling about the pasture which is represented as a grid with N rows and M columns (2 <= N <= 100; 2 <= M <= 100). Keen observer Farmer John has recorded Bessie's position as (R1, C1) at a certain time and then as (R2, C2) exactly T (0 < T <= 15) seconds later. He's not sure if she passed through (R2, C2) before T seconds, but he knows she is there at time T.

FJ wants a program that uses this information to calculate an integer S that is the number of ways a cow can go from (R1, C1) to (R2, C2) exactly in T seconds. Every second, a cow can travel from any position to a vertically or horizontally neighboring position in the pasture each second (no resting for the cows). Of course, the pasture has trees through which no cow can travel.

Given a map with '.'s for open pasture space and '*' for trees, calculate the number of possible ways to travel from (R1, C1) to (R2, C2) in T seconds.

奶牛们在被划分成N行M列(2 <= N <= 100; 2 <= M <= 100)的草地上游走, 试图找到整块草地中最美味的牧草。Farmer John在某个时刻看见贝茜在位置 (R1, C1),恰好T (0 < T <= 15)秒后,FJ又在位置(R2, C2)与贝茜撞了正着。 FJ并不知道在这T秒内贝茜是否曾经到过(R2, C2),他能确定的只是,现在贝茜 在那里。 设S为奶牛在T秒内从(R1, C1)走到(R2, C2)所能选择的路径总数,FJ希望有 一个程序来帮他计算这个值。每一秒内,奶牛会水平或垂直地移动1单位距离( 奶牛总是在移动,不会在某秒内停在它上一秒所在的点)。草地上的某些地方有 树,自然,奶牛不能走到树所在的位置,也不会走出草地。 现在你拿到了一张整块草地的地形图,其中'.'表示平坦的草地,'*'表示 挡路的树。你的任务是计算出,一头在T秒内从(R1, C1)移动到(R2, C2)的奶牛 可能经过的路径有哪些。

输入输出格式

输入格式:

第1 行: 3 个用空格隔开的整数:N,M,T 。 第2..N+1 行: 第i+1 行为M 个连续的字符,描述了草地第i 行各点的情况,保证字符是'.'和'*'中的一个。 第N+2 行: 4 个用空格隔开的整数:R1,C1,R2,C2 。

输出格式:

第1 行: 输出S,含义如题中所述。

输入输出样例

输入样例#1

4 5 6
...*.
...*.
.....
.....
1 3 1 5

输出样例#1

1

说明

样例说明:

草地被划分成4 行5 列,奶牛在6 秒内从第1 行第3 列走到了第1 行第5 列。

奶牛在6 秒内从(1,3)走到(1,5)的方法只有一种(绕过她面前的树)


思路

好久没锻炼dfs了,本题用dfs做。

这题和过河卒那题有点像,数据很毒瘤,不剪枝50封顶。本题可以记忆化(但我太弱了不会)

#include <stdio.h>
#include <iostream>
#include <algorithm>
using namespace std;
int n,m,a[101][101],inx,iny,outx,outy,s1,s2;
int tox[5]={0,1,0,-1,0},toy[5]={0,0,1,0,-1};
void dfs(int x,int y,int f)//f是时间 
{
	int i,j;
	if(f>s1)//如果时间超了 
	{
		return;
	}
	if(abs(x-outx)+abs(y-outy)>s1-f)//这个要剪,距离过远 
	{
		return;
	}
	if(x==outx && y==outy && s1==f)//是否到达终点且时间正好 
	{
		s2++;
		return;
	}
	for(i=1;i<=4;i++)//搜索4个方向 
	{
		int x1=x+tox[i];
		int y1=y+toy[i];
		if(x1>=1 && x1<=n && y1>=1 && y1<=m && a[x1][y1]==0)
		{
			dfs(x1,y1,f+1);
		}
	}
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);
	int i,j;
	char c;
	cin>>n>>m>>s1;
	for(i=1;i<=n;i++)
	{
		for(j=1;j<=m;j++)
		{
			cin>>c;
			if(c=='.')//如果是地 
			{
				a[i][j]=0;
			}
			else
			{
				a[i][j]=1;
			}
		}
	}
	cin>>inx>>iny>>outx>>outy;
	dfs(inx,iny,0);
	cout<<s2<<endl;
	return 0;
}

猜你喜欢

转载自blog.csdn.net/Apro1066/article/details/82766002
2.7
今日推荐