【HDU】4597Play Game-记忆化搜索

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1900    Accepted Submission(s): 1129


 

Problem Description

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

 

Input

The first line contains an integer T (T≤100), indicating the number of cases.
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai (1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

 

Output

For each case, output an integer, indicating the most score Alice can get.

 

Sample Input

 

2 1 23 53 3 10 100 20 2 4 3

 

Sample Output

 

53 105

 

Source

2013 ACM-ICPC吉林通化全国邀请赛——题目重现

 

Recommend

liuyiding   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

dp[la][ra][lb][rb]记录的是在a的区间只剩下la~ra,b的区间只剩下lb~rb的时候,Alice能得到的最大值,那么只需要考虑四种不同的取法并从中取得最优的方案,sum-(Alice上一个状态中Bob拿的值)中取最大

(参考网上大神的思路)

代码:

#include<iostream>
#include<cstring>
#include<cstdio>
#define maxn 55
using namespace std;

int n,dp[maxn][maxn][maxn][maxn];
int a[maxn],b[maxn];

int dfs(int la,int ra,int lb,int rb,int sum)
{
    int maxx=0;
    if(la>ra&&lb>rb)
        return 0;
    if(dp[la][lb][ra][rb])
        return dp[la][lb][ra][rb];
    if(la<=ra)
    {
        maxx = max(maxx,sum-dfs(la+1,ra,lb,rb,sum-a[la]));
        maxx = max(maxx,sum-dfs(la,ra-1,lb,rb,sum-a[ra]));
    }
    if(lb<=rb)
    {
        maxx = max(maxx,sum-dfs(la,ra,lb+1,rb,sum-b[lb]));
        maxx = max(maxx,sum-dfs(la,ra,lb,rb-1,sum-b[rb]));
    }

    dp[la][lb][ra][rb]=maxx;
    return maxx;
}

int main()
{
    int t;cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int sum=0;
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            sum+=a[i];
        }

        for(int i=1;i<=n;i++)
        {
            cin>>b[i];
            sum+=b[i];
        }

        cout<<dfs(1,n,1,n,sum)<<endl;

    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wentong_Xu/article/details/82317968