ACM-ICPC 2018 焦作赛区网络预赛-B-Mathematical Curse

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/C_13579/article/details/82779104

A prince of the Science Continent was imprisoned in a castle because of his contempt for mathematics when he was young, and was entangled in some mathematical curses. He studied hard until he reached adulthood and decided to use his knowledge to escape the castle.

There are NN rooms from the place where he was imprisoned to the exit of the castle. In the i^{th}ith room, there is a wizard who has a resentment value of a[i]a[i]. The prince has MM curses, the j^{th}jth curse is f[j]f[j], and f[j]f[j] represents one of the four arithmetic operations, namely addition('+'), subtraction('-'), multiplication('*'), and integer division('/'). The prince's initial resentment value is KK. Entering a room and fighting with the wizard will eliminate a curse, but the prince's resentment value will become the result of the arithmetic operation f[j]f[j] with the wizard's resentment value. That is, if the prince eliminates the j^{th}jth curse in the i^{th}ith room, then his resentment value will change from xx to (x\ f[j]\ a[i]x f[j] a[i]), for example, when x=1, a[i]=2, f[j]=x=1,a[i]=2,f[j]='+', then xx will become 1+2=31+2=3.

Before the prince escapes from the castle, he must eliminate all the curses. He must go from a[1]a[1] to a[N]a[N] in order and cannot turn back. He must also eliminate the f[1]f[1] to f[M]f[M] curses in order(It is guaranteed that N\ge MN≥M). What is the maximum resentment value that the prince may have when he leaves the castle?

Input

The first line contains an integer T(1 \le T \le 1000)T(1≤T≤1000), which is the number of test cases.

For each test case, the first line contains three non-zero integers: N(1 \le N \le 1000), M(1 \le M \le 5)N(1≤N≤1000),M(1≤M≤5) and K(-1000 \le K \le 1000K(−1000≤K≤1000), the second line contains NN non-zero integers: a[1], a[2], ..., a[N](-1000 \le a[i] \le 1000)a[1],a[2],...,a[N](−1000≤a[i]≤1000), and the third line contains MM characters: f[1], f[2], ..., f[M](f[j] =f[1],f[2],...,f[M](f[j]='+','-','*','/', with no spaces in between.

Output

For each test case, output one line containing a single integer.

样例输入复制

3
2 1 5
2 3
/
3 2 1
1 2 3
++
4 4 5
1 2 3 4
+-*/

样例输出复制

2
6
3

地址:https://nanti.jisuanke.com/t/31711

思路:用dp1[j],dp2[j]分别维护取第j个运算符时的最小值和最大值,然后就过了???

#include<iostream>
#include<cstring>
using namespace std;
typedef long long LL;

const int MAX_N=1005;
const int MAX_M=10;
int n,m,p,T;
int a[MAX_N];
char b[MAX_M];
LL dp1[MAX_M],dp2[MAX_M];

LL Count(LL a,LL b,char c);
int main()
{
	scanf("%d",&T);
	while(T--){
		memset(dp1,0,sizeof(dp1));
		memset(dp2,0,sizeof(dp2));
		scanf("%d%d%d",&n,&m,&p);
		for(int i=1;i<=n;++i)
			scanf("%d",&a[i]);
		scanf("%s",b+1);
		dp1[0]=dp2[0]=p;
		for(int i=1;i<=n;++i)
			for(int j=m;j>=1;--j)
				if(i==j){ //不可取自身 
					dp1[j]=min(Count(dp1[j-1],a[i],b[j]),Count(dp2[j-1],a[i],b[j]));
					dp2[j]=max(Count(dp1[j-1],a[i],b[j]),Count(dp2[j-1],a[i],b[j]));
				}else	if(i>j){	//可取自身 
					dp1[j]=min(dp1[j],min(Count(dp1[j-1],a[i],b[j]),Count(dp2[j-1],a[i],b[j])));
					dp2[j]=max(dp2[j],max(Count(dp1[j-1],a[i],b[j]),Count(dp2[j-1],a[i],b[j])));
				}
		printf("%lld\n",max(dp1[m],dp2[m]));
	}
	
	return 0;
}

LL Count(LL a,LL b,char c)
{
	LL res=0;
	if(c=='+')	res=a+b;
	else	if(c=='-')	res=a-b;
	else	if(c=='*')	res=a*b;
	else	if(c=='/')	res=a/b;
	return res;
}

猜你喜欢

转载自blog.csdn.net/C_13579/article/details/82779104