Features Track——徐州网络赛

  •  31.32%
  •  1000ms
  •  262144K

Morgana is learning computer vision, and he likes cats, too. One day he wants to find the cat movement from a cat video. To do this, he extracts cat features in each frame. A cat feature is a two-dimension vector <xx, yy>. If x_ixi?= x_jxj? and y_iyi? = y_jyj?, then <x_ixi?, y_iyi?> <x_jxj?, y_jyj?> are same features.

So if cat features are moving, we can think the cat is moving. If feature <aa, bb> is appeared in continuous frames, it will form features movement. For example, feature <aa , bb > is appeared in frame 2,3,4,7,82,3,4,7,8, then it forms two features movement 2-3-42−3−4 and 7-87−8.

Now given the features in each frames, the number of features may be different, Morgana wants to find the longest features movement.

Input

First line contains one integer T(1 \le T \le 10)T(1≤T≤10), giving the test cases.

Then the first line of each cases contains one integer nn (number of frames),

In The next nn lines, each line contains one integer k_iki? ( the number of features) and 2k_i2ki?intergers describe k_iki? features in ith frame.(The first two integers describe the first feature, the 33rd and 44th integer describe the second feature, and so on).

In each test case the sum number of features NN will satisfy N \le 100000N≤100000 .

Output

For each cases, output one line with one integers represents the longest length of features movement.

样例输入复制

1
8
2 1 1 2 2
2 1 1 1 4
2 1 1 2 2
2 2 2 1 4
0
0
1 1 1
1 1 1

样例输出复制

3

题目来源

ACM-ICPC 2018 徐州赛区网络预赛

#include <bits/stdc++.h>
using namespace std;
struct haha{
	int x;
	map<long long,int>ww;
}we[100010];
char b[1000];
int main(){
	int t;
	scanf("%d",&t);
	we[0].x=0;
	while(t--){
		int n;
		scanf("%d",&n);
		long long a;
		int b,c;
		int mmax=0;
		for(int i=1;i<=n;i++){
			we[i].ww.clear();
			scanf("%d",&we[i].x);
			for(int j=1;j<=we[i].x;j++){
				scanf("%d %d",&b,&c);
				a=b*1000000000+c;
				if(we[i-1].x==0){
					we[i].ww[a]=1;
				}
				else{
					if(we[i-1].ww[a]){
						we[i].ww[a]=we[i-1].ww[a]+1;
						mmax=max(mmax,we[i].ww[a]);
					}
					else{
						we[i].ww[a]=1;
					}
				}
			}
		}
		printf("%d\n",mmax);
	}
}

猜你喜欢

转载自blog.csdn.net/doublekillyeye/article/details/82563026