树形dp基础Tree Cutting

http://poj.org/problem?id=2378
Tree Cutting
After Farmer John realized that Bessie had installed a “tree-shaped” network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.

Bessie, feeling vindictive, decided to sabotage Farmer John’s network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.

Please help Bessie determine all of the barns that would be suitable to disconnect.
Input
* Line 1: A single integer, N. The barns are numbered 1..N.

Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.
Output
Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word “NONE”.
Sample Input
10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8
Sample Output
3
8
Hint
INPUT DETAILS:
The set of connections in the input describes a “tree”: it connects all the barns together and contains no cycles.

OUTPUT DETAILS:

If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).

树形dp入门题

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
#include<vector>
using namespace std;
const int N=2e5+5;
vector <int>g[10010],ans;
int n,x,y;
int dfs(int x,int f)
{
    int tot=1,maxs=0;
    for(int i=0;i<g[x].size();i++)
    {
        if(g[x][i]==f) continue;
        int t=dfs(g[x][i],x);
        maxs=max(maxs,t);
        tot+=t;
    }
    if(maxs<=n/2&&n-tot<=n/2)
    {
        ans.push_back(x);
    }
    return tot;
}
int main()
{
    scanf("%d",&n);
    for(int i=1;i<n;i++)
    {
        scanf("%d %d",&x,&y);
        g[x].push_back(y);
        g[y].push_back(x);

    }
    dfs(1,-1);
    sort(ans.begin(),ans.end());
    if(ans.size()==0)printf("NONE\n");
    for(int i=0;i<ans.size();i++)
    printf("%d\n",ans[i]);


    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_42825221/article/details/82466591