POJ 3164 最小树形图 (朱刘算法)

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/GYH0730/article/details/82809994

Command Network

Time Limit: 1000MS   Memory Limit: 131072K
Total Submissions: 20151   Accepted: 5792

Description

After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project.

With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon.

Input

The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file.

Output

For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘poor snoopy’.

Sample Input

4 6
0 6
4 6
0 0
7 20
1 2
1 3
2 3
3 4
3 1
3 2
4 3
0 0
1 0
0 1
1 2
1 3
4 1
2 3

Sample Output

31.19
poor snoopy

就是求有向图的最小生成树,模板模板

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
typedef long long ll;
const int MAXN = 105;
const int MAXM = 40010;
const double INF = 1e19;
struct Edge
{
    int u,v;
    double cost;
}edge[MAXM];
int pre[MAXN],id[MAXN],visit[MAXN];
double in[MAXN];
double zhuliu(int root,int n,int m,Edge edge[])
{
    double res = 0;
    int u,v;
    while(1) {
        for(int i = 0; i < n; i++)
            in[i] = INF;
        for(int i = 0; i < m; i++)
            if(edge[i].u != edge[i].v && edge[i].cost < in[edge[i].v]) {
                pre[edge[i].v] = edge[i].u;
                in[edge[i].v] = edge[i].cost;
            }
        for(int i = 0; i < n; i++)
            if(i != root && in[i] == INF)
                return -1;
        int tn = 0;
        memset(id,-1,sizeof(id));
        memset(visit,-1,sizeof(visit));
        in[root] = 0;
        for(int i = 0; i < n; i++) {
            res += in[i];
            v = i;
            while(visit[v] != i && id[v] == -1 && v != root) {
                visit[v] = i;
                v = pre[v];
            }
            if(v != root && id[v] == -1) {
                for(int u = pre[v]; u != v; u = pre[u])
                    id[u] = tn;
                id[v] = tn++;
            }
        }
        if(tn == 0) break;
        for(int i = 0; i < n; i++)
            if(id[i] == -1)
                id[i] = tn++;
        for(int i = 0; i < m;) {
            v = edge[i].v;
            edge[i].u = id[edge[i].u];
            edge[i].v = id[edge[i].v];
            if(edge[i].u != edge[i].v)
                edge[i++] .cost -= in[v];
            else
                swap(edge[i],edge[--m]);
        }
        n = tn;
        root = id[root];
    }
    return res;
}
double x[MAXN],y[MAXN],g[MAXN][MAXN];
double dis(int u,int v)
{
    double res = (x[u] - x[v]) * (x[u] - x[v]) + (y[u] - y[v]) * (y[u] - y[v]);
    return sqrt(res);
}
int main(void)
{
    int n,m,u,v;
    while(scanf("%d %d",&n,&m) != EOF) {
        for(int i = 0; i < n; i++) {
            scanf("%lf %lf",&x[i],&y[i]);
        }
        for(int i = 0; i < n; i++) {
            for(int j = 0; j < n; j++) {
                g[i][j] = INF;
            }
        }
        while(m--) {
            scanf("%d %d",&u,&v);
            u--,v--;
            g[u][v] = dis(u,v);
        }
        int L = 0;
        for(int i = 0; i < n; i++)
            for(int j = 0; j < n; j++)
                if(g[i][j] < INF) {
                    edge[L].u = i;
                    edge[L].v = j;
                    edge[L++].cost = g[i][j];
                }
        double ans = zhuliu(0,n,L,edge);
        if(ans == -1) printf("poor snoopy\n");
        else printf("%.2lf\n",ans);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/GYH0730/article/details/82809994