数组元素循环右移问题 java

一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(≥0)个位置,即将A中的数据由(A​0​​A​1​​⋯A​N−1​​)变换为(A​N−M​​⋯A​N−1​​A​0​​A​1​​⋯A​N−M−1​​)(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?

输入格式:

每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。

输出格式:

在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。

输入样例:

6 2
1 2 3 4 5 6

输出样例:

5 6 1 2 3 4
import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
              Scanner sc=new Scanner (System.in);
              int N=sc.nextInt();
              int m=sc.nextInt();
              sc.nextLine();
              String ar[]=sc.nextLine().split(" ");
              String a[]=new String [ar.length];
              for(int i=0;i<ar.length;i++) {
            	  a[(i+m)%ar.length]=ar[i];
              }
              for(int i=0;i<a.length-1;i++) {
            	  System.out.print(a[i]+" ");
              }
              System.out.print(a[a.length-1]);
	}

}

思路分析,对超过数组长度的数字进行对长度求模,没超过的相加位移长度就好了,这里我建了一个新的数组来存放变换后的数字

猜你喜欢

转载自blog.csdn.net/qq_41859891/article/details/82766015