BE, GE or NE (PN 结点)

版权声明:小白一个,欢迎各位指错。 https://blog.csdn.net/qq_36424540/article/details/82592697

In a world where ordinary people cannot reach, a boy named "Koutarou" and a girl named "Sena" are playing a video game. The game system of this video game is quite unique: in the process of playing this game, you need to constantly face the choice, each time you choose the game will provide 1−31-31−3 options, the player can only choose one of them. Each option has an effect on a "score" parameter in the game. Some options will increase the score, some options will reduce the score, and some options will change the score to a value multiplied by −1-1−1 .

That is, if there are three options in a selection, the score will be increased by 111, decreased by 111, or multiplied by −1-1−1. The score before the selection is 888. Then selecting option 111 will make the score become 999, and selecting option 222 will make the score 777 and select option 333 to make the score −8-8−8. Note that the score has an upper limit of 100100100 and a lower limit of −100-100−100. If the score is 999999 at this time, an option that makes the score +2+2+2 is selected. After that, the score will change to 100100100 and vice versa .

After all the choices have been made, the score will affect the ending of the game. If the score is greater than or equal to a certain value kkk, it will enter a good ending; if it is less than or equal to a certain value lll, it will enter the bad ending; if both conditions are not satisfied, it will enter the normal ending. Now, Koutarou and Sena want to play the good endings and the bad endings respectively. They refused to give up each other and finally decided to use the "one person to make a choice" way to play the game, Koutarou first choose. Now assume that they all know the initial score, the impact of each option, and the kkk, lll values, and decide to choose in the way that works best for them. (That is, they will try their best to play the ending they want. If it's impossible, they would rather normal ending than the ending their rival wants.)

Koutarou and Sena are playing very happy, but I believe you have seen through the final ending. Now give you the initial score, the kkk value, the lll value, and the effect of each option on the score. Can you answer the final ending of the game?

Input

The first line contains four integers n,m,k,ln,m,k,ln,m,k,l(1≤n≤10001\le n \le 10001≤n≤1000, −100≤m≤100-100 \le m \le 100−100≤m≤100 , −100≤l<k≤100-100 \le l < k \le 100−100≤l<k≤100 ), represents the number of choices, the initial score, the minimum score required to enter a good ending, and the highest score required to enter a bad ending, respectively.

Each of the next nnn lines contains three integers a,b,ca,b,ca,b,c(a≥0a\ge 0a≥0 , b≥0b\ge0b≥0 ,c=0c=0c=0 or c=1c=1c=1),indicates the options that appear in this selection,in which a=0a=0a=0 means there is no option to increase the score in this selection, a>0a>0a>0 means there is an option in this selection to increase the score by aaa ; b=0b=0b=0 means there is no option to decrease the score in this selection, b>0b>0b>0 means there is an option in this selection to decrease the score by bbb; c=0c=0c=0 means there is no option to multiply the score by −1-1−1 in this selection , c=1c=1c=1 means there is exactly an option in this selection to multiply the score by −1-1−1. It is guaranteed that a,b,ca,b,ca,b,c are not equal to 000 at the same time.

Output

One line contains the final ending of the game. If it will enter a good ending,print "Good Ending"(without quotes); if it will enter a bad ending,print "Bad Ending"(without quotes);otherwise print "Normal Ending"(without quotes).

样例输入1

3 -8 5 -5
3 1 1
2 0 1
0 2 1

样例输出1

Good Ending

样例输入2

3 0 10 3
0 0 1
0 10 1
0 2 1

样例输出2

Bad Ending
#include<bits/stdc++.h>
using namespace std;

typedef long long LL;
#define rep(i,a,b) for(int i=a;i<b;++i)
#define per(i,a,b) for(int i=b-1;i>=a;--i)


const int maxn=1010;

unordered_map<int,int> id;
int dp[maxn][220];
int a[maxn],b[maxn],c[maxn];

int N,M,K,L;

/*
主要是考察 PN值吧,也就是 必胜态 和必败态

我们考虑 所有的方案, 肯定是 3^n, 这样的复杂度,恐怕。。。

所以我们可以记忆化搜索, 一共只有 1000*200 种状态, 所以一定是可以算出来的

一个点为必胜态,当且仅当他的后继 有一个必败态
一个点为必败态,当且仅当他所有的后继 都是必胜态

考虑这道题, 如果第一个人可以赢,他不会选择平, 更不会选择输
对于第二个人同理


核心:重复+记忆化 
*/

int dfs(int pos,int sco){
	if(pos==N){
		if(sco>=K)return 0;//good
		if(sco<=L)return 2;//bad
		return 1;//draw
	}

	if(dp[pos][id[sco]]!=-1)return dp[pos][id[sco]];

	//后手
	if(pos&1){
		int res=0;
		if(a[pos]){
			res=max(res,dfs(pos+1,min(100,sco+a[pos])));
		}
		if(b[pos]){
			res=max(res,dfs(pos+1,max(-100,sco-b[pos])));
		}
		if(c[pos]){
			res=max(res,dfs(pos+1,-sco));
		}
		return dp[pos][id[sco]]=res;
	}
	else{
		int res=2;
		if(a[pos]){
			res=min(res,dfs(pos+1,min(100,sco+a[pos])));
		}
		if(b[pos]){
			res=min(res,dfs(pos+1,max(-100,sco-b[pos])));
		}
		if(c[pos]){
			res=min(res,dfs(pos+1,-sco));
		}
		return dp[pos][id[sco]]=res;
	}
}

int main(){
	memset(dp,-1,sizeof(dp));
	rep(i,0,210)id[i-100]=i;

	scanf("%d %d %d %d",&N,&M,&K,&L);
	rep(i,0,N){
		scanf("%d %d %d",&a[i],&b[i],&c[i]);
	}

	int ans=dfs(0,M);
	if(ans==0){
		printf("Good Ending\n");
	}
	else if(ans==1){
		printf("Normal Ending\n");
	}
	else{
		printf("Bad Ending\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_36424540/article/details/82592697
今日推荐