1095 Cars on Campus(30 分)(cj)

1095 Cars on Campus(30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in accending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

说实话 这题真的考验编程的基础能力,把自己想的变成代码。

读入数据  -- 去掉无效数据 -- 数据整理 -- 遍历 -- 遍历

code 

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <vector>
#include <stdio.h>
#include <map>
#include <algorithm>
using namespace std;
class car {
public:
	string carid;
	int time, status;
};
vector<car> vcar;
vector<bool> vis;
map<string, int> mptime;
bool cmp(const car& a, const car& b);
inline int setime(int hh, int mm, int ss);
void printime(int t);
int main() {
	int n, k;
	cin >> n >> k;
	int hh, mm, ss;
	string status;
	car x;
	for (int i = 0; i < n; ++i) {
		cin >> x.carid;
		scanf(" %d:%d:%d", &hh, &mm, &ss);
		x.time = setime(hh, mm, ss);
		cin>>status;
		if (status == "in") x.status = 1;
		else x.status = 0;
		if (x.time >= setime(0, 0, 0) && x.time <= setime(23, 59, 59)) {
			vcar.push_back(x);
			vis.push_back(0);
		}
	}
	sort(vcar.begin(), vcar.end(),cmp);
	for (int i = 0; i < vcar.size(); ++i) {
		if (vcar[i].status == 1) {
			for (int j = i + 1; j < vcar.size(); ++j) {
				if (vcar[j].carid == vcar[i].carid) {
					if (vcar[j].status != 1) {
						vis[j] = 1;
						vis[i] = 1;
						mptime[vcar[i].carid] += vcar[j].time - vcar[i].time;
					}
					break;
				}
			}
		}
	}
	int pos = 0;
	int num = 0;
	for (int i = 0; i < k; ++i) {
		scanf(" %d:%d:%d", &hh, &mm, &ss);
		int qtime = setime(hh, mm, ss);
		for (int i = pos; i < vcar.size(); ++i) {
			if(vcar[i].time>qtime){
				pos = i;
				break;
			}
			if (vcar[i].time <= qtime && vis[i] == 1) {
				if (vcar[i].status) num++;
				else num--;
			}
		}
		cout << num << endl;
	}
	vector<string> vres;
	int maxltime = 0;
	for (auto it = mptime.begin(); it != mptime.end(); ++it) {
		if (it->second > maxltime) {
			vres.clear();
			maxltime = it->second;
			vres.push_back(it->first);
		}
		else if (it->second == maxltime) {
			vres.push_back(it->first);
		}
	}
	for (int i = 0; i < vres.size(); ++i) {
		cout << vres[i] << ' ';
	}
	printime(maxltime);
	system("pause");
	return 0;
}
int setime(int hh, int mm, int ss) {
	return hh * 3600 + mm * 60 + ss;
}
void printime(int t) {
	printf("%02d:%02d:%02d", t / 3600, t % 3600 / 60, t % 60);
}
bool cmp(const car& a, const car& b) {
	if (a.time == b.time) return a.carid < b.carid;
	return a.time < b.time;
}

猜你喜欢

转载自blog.csdn.net/Cute_jinx/article/details/82491354