1095 Cars on Campus (30分)【结构体排序】

1095 Cars on Campus (30分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

题目大意:

给出n条记录,每条记录给出一辆车的车牌号、当前时刻以及进出学校的情况(in or out)。然后给出k个查询,,每个查询给出一个时刻,输出在这个时刻校园内的车辆数。查询完毕后输出在学校内停留时间最长的车辆的车牌号(如果有多个,就一并输出)和对应的停留时间。注意:对于一辆车来说,配对的in和out必须满足在把这辆车的记录按时间排序之后,在它们之间不允许出现其他in或者out的记录;否则,将被视为无效记录。

解题思路:

首先定义一个record结构体存储所有的进出记录,同时为了时间处理方便,这里把时间统一转换为以s为单位。然后定义一个map,用 来记录每一辆车在校园中停留的总时长。

该题唯一需要特别注意的地方是过程较为复杂,需要细心。

#include<iostream>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
#define maxn 10010

struct record {
	int time;      //时间,统一s为单位
	string id;     
	string stat;   //出入状态
}all[maxn],valid[maxn];

map<string, int>parkTime;

int timeToMin(int hh, int mm, int ss)
{
	return hh * 3600 + mm * 60 + ss;
}

int cmp1(record a, record b)
{
	if (a.id == b.id)
		return a.time < b.time;
	else return a.id < b.id;
}

int cmp2(record a, record b)
{
	return a.time < b.time;
}

int main()
{
	int n, k;
	cin >> n >> k;
	for (int i = 0; i < n; i++)
	{
		int hh, mm, ss;
		cin >> all[i].id;
		scanf("%d:%d:%d", &hh, &mm, &ss);
		cin >> all[i].stat;
		all[i].time = timeToMin(hh, mm, ss);
	}
	sort(all, all + n, cmp1);
	int maxtime = 0;
	int cnt = 0;
	for (int i = 0; i < n - 1; i++)
	{
		if (all[i].id == all[i + 1].id&&all[i].stat == "in"&&all[i+1].stat == "out")
		{
			valid[cnt++] = all[i];
			valid[cnt++] = all[i + 1];
			int time = all[i + 1].time - all[i].time;
			if (parkTime.count(all[i].id) == 0)
				parkTime[all[i].id] = 0;                 //如果map中还没有该车
			parkTime[all[i].id] += time;             //停车时间增加
			maxtime = max(maxtime, parkTime[all[i].id]);
		}
	}
	sort(valid, valid + cnt, cmp2);
	int now = 0, carCnt = 0;
	for (int i = 0; i < k; i++)
	{
		int hh, mm, ss;
		scanf("%d:%d:%d", &hh, &mm, &ss);
		int time = timeToMin(hh, mm, ss);
		while (now < cnt&&valid[now].time <= time)
		{
			if (valid[now].stat == "in")
				carCnt++;
			else carCnt--;
			now++;
		}
		cout << carCnt << endl;
	}
	map<string, int>::iterator it;
	for (it = parkTime.begin(); it != parkTime.end(); it++)
	{
		if (it->second == maxtime)
			cout << it->first<<" ";
	}
	printf("%02d:%02d:%02d\n", maxtime / 3600, maxtime % 3600 / 60, maxtime % 60);
	return 0;
}
发布了119 篇原创文章 · 获赞 22 · 访问量 1万+

猜你喜欢

转载自blog.csdn.net/lovecyr/article/details/104728499