Biorhythms - poj1006 - 中国剩余定理(互质)

Biorhythms

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 146409   Accepted: 47252

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier. 
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak. 

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form: 

Case 1: the next triple peak occurs in 1234 days. 

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

Source

East Central North America 1999

题意:

看题就看了好久好久……

就是说有3个周期,每个周期持续时间是23,28,33(可以看出来这三个数是互质的),输入4个数:p,e,i,d

p,e,i,代表3个周期的高峰,d是当前的天数,问你从当前天数开始数多少天能到达triple peak(这一天3个周期都到达高峰)

思路:

若不考虑d,则我们hin容易发现天数x满足:

x%23=p

x%28=i

x%33=i

然后就用中国剩余定理求解出最小的x,这时候要讨论啦

若x<=d,满足的天数是x+lcm*i,我们知道d的值最多为365,而lcm=21252,所以就+1个lcm就行了,返回x+lcm-d

(注意等于d也算,看样例可以知道不算当天d)

若x>d,就可以直接返回x-d啦。

代码如下:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<vector>
using namespace std;
#define ll long long
int m[]={0,23,28,33};
int D,a[5];

int extgcd(int a,int b,int &x,int &y){
	int d=a;
	if(b!=0){
		d=extgcd(b,a%b,y,x);
		y-=(a/b)*x;
	}
	else {x=1;y=0;}
	return d;
}

ll work(){
	int d,x,y,res=0,lcm=1;
	for(int i=1;i<=3;i++)lcm=lcm*m[i];
	for(int i=1;i<=3;i++){
		int kl=lcm/m[i];
		d=extgcd(kl,m[i],x,y);
		x=(x%m[i]+m[i])%m[i];
		res=(res+a[i]*x*kl)%lcm;
	} 
	//printf("res=%d d=%d\n",res,d);
	if(res<=D)return res+lcm-D;
	else return res-D;
}

int main(){
	int cas=1;
	while(scanf("%d%d%d%d",&a[1],&a[2],&a[3],&D)!=EOF){
		if(a[1]==-1&&a[2]==-1&&a[3]==-1&&D==-1)break;
		ll ans=work();
		printf("Case %d: the next triple peak occurs in %lld days.\n",cas++,ans);
	}
}

猜你喜欢

转载自blog.csdn.net/m0_37579232/article/details/82118212
今日推荐