HDU - 5289 Assignment (RMQ+二分)

版权声明:本文为博主原创文章,转载请附上注明就行_(:з」∠)_。 https://blog.csdn.net/vocaloid01/article/details/82083184

Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.

Input

In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,a[n](0<=a[i]<=10^9),indicate the i-th staff’s ability.

Output

For each test,output the number of groups.

Sample Input

2
4 2
3 1 2 4
10 5
0 3 4 5 2 1 6 7 8 9

Sample Output

5
28
     

Hint

First Sample, the satisfied groups include:[1,1]、[2,2]、[3,3]、[4,4] 、[2,3] 
        

题意:

N个数,问满足区间内最大数与最小数的差值小于给定的k的区间是多少。

题解:

先用ST求出每个区间的最大值和最小值,然后枚举每个点为左端点L,二分找满足要求的最远右端点R,则其中有R-L+1个区间满足。

代码:

#include <bits/stdc++.h>

using namespace std;

const int MAXN = 100005;

int a[MAXN];
int ma[MAXN][20],mi[MAXN][20];

void ST_prework(int n){
	for(int i=1 ; i<=n ; ++i)ma[i][0] = mi[i][0] = a[i];
	int t = log(n) / log(2) + 1;
	for(int i=1 ; i<t ; ++i){
		for(int j=1 ; j<=n-(1<<i)+1 ; ++j){
			ma[j][i] = max(ma[j][i-1],ma[j+(1<<(i-1))][i-1]);
			mi[j][i] = min(mi[j][i-1],mi[j+(1<<(i-1))][i-1]);
		}
	}
} 

int ST_query(int l,int r){
	int k = log(r-l+1) / log(2);
	return max(ma[l][k],ma[r-(1<<k)+1][k]) - min(mi[l][k],mi[r-(1<<k)+1][k]);
}

int main(){
	
	int T,n,k;
	scanf("%d",&T);
	while(T--){
		scanf("%d %d",&n,&k);
		for(int i=1 ; i<=n ; ++i)scanf("%d",&a[i]);
		ST_prework(n);
		long long ans = 0;
		for(int i=1 ; i<=n ; ++i){
			int l = i,r = n;
			while(l <= r){
				int m = l + (r-l)/2;
				if(ST_query(i,m) < k)l = m + 1;
				else r = m - 1; 
			}
			ans += r - i + 1;
		}
		printf("%lld\n",ans);
	}
	
	return 0;
}

猜你喜欢

转载自blog.csdn.net/vocaloid01/article/details/82083184