[欧拉回路] poj 1300 Door Man

题目链接:

http://poj.org/problem?id=1300

Door Man
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 2137   Accepted: 857

Description

You are a butler in a large mansion. This mansion has so many rooms that they are merely referred to by number (room 0, 1, 2, 3, etc...). Your master is a particularly absent-minded lout and continually leaves doors open throughout a particular floor of the house. Over the years, you have mastered the art of traveling in a single path through the sloppy rooms and closing the doors behind you. Your biggest problem is determining whether it is possible to find a path through the sloppy rooms where you: 

  1. Always shut open doors behind you immediately after passing through 
  2. Never open a closed door 
  3. End up in your chambers (room 0) with all doors closed 

In this problem, you are given a list of rooms and open doors between them (along with a starting room). It is not needed to determine a route, only if one is possible. 

Input

Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. 
A single data set has 3 components: 

  1. Start line - A single line, "START M N", where M indicates the butler's starting room, and N indicates the number of rooms in the house (1 <= N <= 20). 
  2. Room list - A series of N lines. Each line lists, for a single room, every open door that leads to a room of higher number. For example, if room 3 had open doors to rooms 1, 5, and 7, the line for room 3 would read "5 7". The first line in the list represents room 0. The second line represents room 1, and so on until the last line, which represents room (N - 1). It is possible for lines to be empty (in particular, the last line will always be empty since it is the highest numbered room). On each line, the adjacent rooms are always listed in ascending order. It is possible for rooms to be connected by multiple doors! 
  3. End line - A single line, "END" 

Following the final data set will be a single line, "ENDOFINPUT". 

Note that there will be no more than 100 doors in any single data set.

Output

For each data set, there will be exactly one line of output. If it is possible for the butler (by following the rules in the introduction) to walk into his chambers and close the final open door behind him, print a line "YES X", where X is the number of doors he closed. Otherwise, print "NO".

Sample Input

START 1 2
1

END
START 0 5
1 2 2 3 3 4 4




END
START 0 10
1 9
2
3
4
5
6
7
8
9

END
ENDOFINPUT

Sample Output

YES 1
NO
YES 10

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题目意思:

有n个房间,房间之间通过门连接,知道门连接的房间情况,求从m号房间能否经过所有的门一次,并且回到0号门。

解题思路:

把房间看成节点,门看成边,由题意知是一个连通图,然后判断是否存在从m到0的欧拉通路。

统计各点的度数即可。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 22

int nu[Maxn],n,m;
char temp[Maxn];

int main()
{
    //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   while(scanf("%s",temp))
   {
       if(temp[3]=='O')
            break;
       scanf("%d%d",&m,&n);
       memset(nu,0,sizeof(nu));
       getchar();
       int ans=0;

       for(int i=0;i<n;i++)
       {
           int la=0;
           char c;
           while((c=getchar())!='\n')
           {
               if(c==' ')
               {
                   ans++;
                   nu[i]++;
                   nu[la]++;
                   la=0;
                   while((c=getchar())==' ');
                   if(c=='\n')
                        break;
                   la=c-'0';
               }
               else
                  la=la*10+c-'0';
           }
           if(la)
           {
               nu[i]++;
               nu[la]++;
               ans++;
           }
       }
       //printf("ans:%d :%d %d\n",ans,nu[0],nu[1]);
       //system("pause");

       int ocnt=0,a[3];
       for(int i=0;i<n;i++)
           if(nu[i]&1)
           {
               ocnt++;
               if(ocnt>2)
                    break;
               a[ocnt]=i;
           }

        gets(temp);
        if(ocnt>2||ocnt==1)
            printf("NO\n");
        else if(!ocnt)
        {
            if(!m)
                printf("YES %d\n",ans);
            else
                printf("NO\n");
        }
        else
        {
            if(a[1]>a[2])
                swap(a[1],a[2]);
            if(!a[1]&&a[2]==m)
                printf("YES %d\n",ans);
            else
                printf("NO\n");
        }


   }
    return 0;
}



猜你喜欢

转载自blog.csdn.net/cc_again/article/details/39736819
今日推荐