ACM-ICPC 2018 南京赛区网络预赛 A-An Olympian Math Problem

Alice, a student of grade 66, is thinking about an Olympian Math problem, but she feels so despair that she cries. And her classmate, Bob, has no idea about the problem. Thus he wants you to help him. The problem is:

We denote k!:

k! =1 × 2 × ⋯ × (k − 1) × k

We denote S:

S = 1 × 1! + 2 × 2! + ⋯ + (n − 1) × (n − 1)!

Then S module n is ____________

You are given an integer n.

You have to calculate S modulo n.

Input

The first line contains an integer T(T≤1000), denoting the number of test cases.

For each test case, there is a line which has an integer nn.

It is guaranteed that 2 ≤ n ≤ 1e18.

Output

For each test case, print an integer SS modulo nn.

Hint

The first test is: S = 1 × 1 != 1, and 1 modulo 2 is 1.

The second test is: S = 1 × 1! + 2 × 2! = 5 , and 5 modulo 3 is 2.

样例输入

2
2
3

样例输出

1
2
#include <iostream>
#include <vector>
#include <cstdio>
#include <string>
#include <cstring>
#include <map>
#include <algorithm>
#include <queue>
#include <set>
#include <cmath>
#include <sstream>
#include <stack>
#include <fstream>
#include <ctime>
#pragma warning(disable:4996);
#define mem(sx,sy) memset(sx,sy,sizeof(sx))
typedef long long ll;
typedef unsigned long long ull;
const double eps = 1e-8;
const double PI = acos(-1.0);
const ll llINF = 0x3f3f3f3f3f3f3f3f;
const int INF = 0x3f3f3f3f;
using namespace std;
//#define pa pair<int, int>
//const int maxn = 1000005;
//const int mod = 1e9 + 7;
int main() {
	int T, Case = 0;
	scanf("%d", &T);
	while (T--) {
		ll n;
		scanf("%lld", &n);
		printf("%lld\n", n - 1);
	}
}

猜你喜欢

转载自blog.csdn.net/qq_23502651/article/details/82290474